summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-22 21:01:34 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-07 22:00:47 +0100
commit3eca71d4a7efae21f7d8ac11d3adf8876d422f07 (patch)
tree9bd8cbdd3400d3a0e84ab425662978236f4c498d /gnu
parent8dc467d78804e79640711e38b6e66660347033a4 (diff)
downloadguix-patches-3eca71d4a7efae21f7d8ac11d3adf8876d422f07.tar
guix-patches-3eca71d4a7efae21f7d8ac11d3adf8876d422f07.tar.gz
gnu: cbqn-bootstrap: Install regular files rather than copying them recursively.
* gnu/packages/bqn.scm (cbqn-bootstrap)[arguments]: Reindent. <#:phases>{install}: Use ‘install-file’ rather than ‘copy-recursively’ for “bqn”.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bqn.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index d0558c3ef8..5029bebe8b 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -141,22 +141,23 @@ the same author.")
"0w38fhwf20drkyijy6nfnhmc5g5gw0zmzgmy1q605x57znlj85a2"))))
(build-system gnu-build-system)
(arguments
- (list #:tests? #f ;skipping tests for bootstrap
- #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
- #:phases #~(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'generate-bytecode
- (lambda* (#:key inputs #:allow-other-keys)
- (system (string-append #+dbqn
- "/bin/dbqn ./genRuntime "
- #+bqn-sources))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p (string-append #$output "/bin"))
- (chmod "BQN" #o755)
- (copy-recursively "BQN"
- (string-append #$output
- "/bin/bqn")))))))
+ (list
+ #:tests? #f ; skipping tests for bootstrap
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'generate-bytecode
+ (lambda* (#:key inputs #:allow-other-keys)
+ (system (string-append #+dbqn
+ "/bin/dbqn ./genRuntime "
+ #+bqn-sources))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append #$output "/bin"))
+ (chmod "BQN" #o755)
+ (rename-file "BQN" "bqn")
+ (install-file "bqn" (string-append #$output "/bin")))))))
(native-inputs (list dbqn bqn-sources))
(inputs (list icedtea-8 libffi))
(synopsis "BQN implementation in C")