summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 07:45:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:30 +0200
commit3e62196230dab1699d239e2337af93edf763f55c (patch)
treedf0ceeb365bb3a7176b102d068e64e5775cfe561 /gnu
parentebc30bccb820ce7efbfdab648aff406561905538 (diff)
downloadguix-patches-3e62196230dab1699d239e2337af93edf763f55c.tar
guix-patches-3e62196230dab1699d239e2337af93edf763f55c.tar.gz
gnu: Add texlive-xfor.
* gnu/packages/tex.scm (texlive-xfor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d0b4c70423..2efbb98ef9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12510,6 +12510,29 @@ computers). XeTeX's immediate output is an extended variant of DVI format,
which is ordinarily processed by a tightly bound processor (called
@code{xdvipdfmx}), that produces PDF.")
(license license:x11)))
+
+(define-public texlive-xfor
+ (package
+ (name "texlive-xfor")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xfor/"
+ "source/latex/xfor/"
+ "tex/latex/xfor/")
+ (base32
+ "1j241j8sixqkaj2xmcvmrfwm1sdw6xdssnzml1bjs54rqzyh768a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xfor")
+ (synopsis "Reimplementation of the LaTeX @code{for-loop} macro")
+ (description
+ "The package redefines the LaTeX internal @code{\\@@for} macro so that
+the loop may be prematurely terminated. The action is akin to the C/Java
+break statement, except that the loop does not terminate until the end of the
+current iteration.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar