summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-01-04 18:53:03 +0100
committerDavid Craven <david@craven.ch>2017-01-04 19:10:01 +0100
commit3dcaa1226dc8bbe63cfed27f0d566deaefc5fefd (patch)
treee6a724b840b5a711a6843b6b272c335aaa0f3215 /gnu
parent337273e41f6bb9486424d0bb636e69f9ca55d88f (diff)
downloadguix-patches-3dcaa1226dc8bbe63cfed27f0d566deaefc5fefd.tar
guix-patches-3dcaa1226dc8bbe63cfed27f0d566deaefc5fefd.tar.gz
gnu: ocamlmod: Enable tests.
Followup to 93eeadf0226078a6a9ecf57f84446044b4be249b. * gnu/packages/ocaml.scm (ocamlmod)[arguments]: Enable tests. Problem reported by Julien Lepiller <julien@lepiller.eu>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4313bde8a8..93020f1c06 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -834,7 +834,10 @@ files in these formats.")
(native-inputs
`(("ounit" ,ocaml-ounit)))
(arguments
- `(#:tests? #f)) ; tests are done during build
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Tests are done during build.
+ (delete 'check))))
(home-page "https://forge.ocamlcore.org/projects/ocamlmod")
(synopsis "Generate modules from OCaml source files")
(description "Generate modules from OCaml source files.")