summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-27 23:34:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 02:18:47 +0200
commit3d320ae1af61ad7e3a520e50b67d5ef836ba865d (patch)
treee382992b72e685e0ffb7381b74e347ba009eebd9 /gnu
parent44831ecb11efc776a8e74ca3ff382c3129f07bcd (diff)
downloadguix-patches-3d320ae1af61ad7e3a520e50b67d5ef836ba865d.tar
guix-patches-3d320ae1af61ad7e3a520e50b67d5ef836ba865d.tar.gz
gnu: python2-ttystatus: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python2-ttystatus)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3aebff078b..38765904b3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14275,13 +14275,13 @@ iterating over input files.")
(version "0.36")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/ttystatus/snapshot/ttystatus-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://git.liw.fi/ttystatus")
+ (commit (string-append "ttystatus-" version))))
(sha256
- (base32
- "06mdk4d19zw2j3is54gndhzl396g3xc8k52m7i86z69s9hcz71by"))))
+ (base32 "1vwr086yi5wky1zc7jqq49fl8yvzqnp9a7rrg67arc55j4awsn5l"))
+ (file-name (git-file-name name version))))
(build-system python-build-system)
(native-inputs
`(("python2-coverage-test-runner" ,python2-coverage-test-runner)