summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-16 21:27:21 +0200
committerJelle Licht <jlicht@fsfe.org>2021-05-16 21:31:48 +0200
commit3c5849f3ecce4e3773fa69634be8c91519e67f9b (patch)
tree9736cfca02bdcd533ace6b12f5c19187e07e93f0 /gnu
parent860ca285b64ea22441a72c26c4715ccfc28a5b9f (diff)
downloadguix-patches-3c5849f3ecce4e3773fa69634be8c91519e67f9b.tar
guix-patches-3c5849f3ecce4e3773fa69634be8c91519e67f9b.tar.gz
gnu: emacs-orderless: Update to 0.6.
* gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 0.6. [native-inputs]: Add texinfo. [arguments]<#:phases>: Install manual.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e2d1707744..7a62b6b7ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7570,7 +7570,7 @@ interface.")
(define-public emacs-orderless
(package
(name "emacs-orderless")
- (version "0.5")
+ (version "0.6")
(source
(origin
(method git-fetch)
@@ -7578,9 +7578,20 @@ interface.")
(url "https://github.com/oantolin/orderless")
(commit version)))
(sha256
- (base32 "032lfwflkpaxbcxl4jf438vapswsdagipjczcn30sc4dfdh3p42c"))
+ (base32 "1javw5n3h3iv7f433b2ack49aka1jdpp8yxnaahzg5qbvr80hnay"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "makeinfo" "orderless.texi")
+ (install-file "orderless.info"
+ (string-append (assoc-ref outputs "out")
+ "/share/info")))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
(home-page "https://github.com/oantolin/orderless")
(synopsis "Emacs completion style that matches multiple regexps in any order")
(description "This package provides an orderless completion style that