summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-12 14:07:34 -0500
committerLeo Famulari <leo@famulari.name>2021-03-12 14:10:31 -0500
commit35b3ab8e5748d9911ae7a0189065d0c25392895b (patch)
tree7f5bae4224a668e39cbc18b53c4dc5f7831d183e /gnu
parenta5a5ec560305a4f59ce4da9b622dfe263eed737d (diff)
downloadguix-patches-35b3ab8e5748d9911ae7a0189065d0c25392895b.tar
guix-patches-35b3ab8e5748d9911ae7a0189065d0c25392895b.tar.gz
gnu: libtiff: Fix documentation directory name in grafted replacement.
Fixes <https://bugs.gnu.org/47107>. This is a followup to commit 6320700b114f09c09fbe613e2032abe077d28583. * gnu/packages/image.scm (libtiff/fixed)[name, arguments]: New fields.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 29e88af231..4f249b7622 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -616,6 +616,7 @@ collection of tools for doing simple manipulations of TIFF images.")
(define-public libtiff/fixed
(package
(inherit libtiff)
+ (name "libtiff")
(version "4.2.0")
(source
(origin
@@ -624,7 +625,14 @@ collection of tools for doing simple manipulations of TIFF images.")
version ".tar.gz"))
(sha256
(base32
- "1jrkjv0xya9radddn8idxvs2gqzp3l2b1s8knlizmn7ad3jq817b"))))))
+ "1jrkjv0xya9radddn8idxvs2gqzp3l2b1s8knlizmn7ad3jq817b"))))
+ (arguments
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ `(#:configure-flags (list (string-append "--with-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/"
+ ,name "-" ,version)
+ "--disable-static")))))
(define-public leptonica
(package