summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 12:09:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 18:04:15 +0200
commit35188a82570348c1c47dadf94bd273942a75c20a (patch)
tree5b63fdcaaf3a74c15481231d90b0f8ddeb0ac911 /gnu
parent23bc34e443abfc974b3d5ab45717072a7b6cbe1b (diff)
downloadguix-patches-35188a82570348c1c47dadf94bd273942a75c20a.tar
guix-patches-35188a82570348c1c47dadf94bd273942a75c20a.tar.gz
gnu: upower: Build from Git sources.
* gnu/packages/gnome.scm (upower)[source]: Use GIT-FETCH and GIT-FILE-NAME. Adjust snippet. [native-inputs]: Add autoconf, automake, gtk-doc, libtool, and which. * gnu/packages/patches/upower-builddir.patch: Adjust to Makefile.am.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm62
-rw-r--r--gnu/packages/patches/upower-builddir.patch24
2 files changed, 54 insertions, 32 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 03a12f5f15..2a493fc40b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5394,27 +5394,32 @@ faster results and to avoid unnecessary server load.")
(package
(name "upower")
(version "0.99.11")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://upower.freedesktop.org/releases/"
- "upower-" version ".tar.xz"))
- (sha256
- (base32
- "1vxxvmz2cxb1qy6ibszaz5bskqdy9nd9fxspj9fv3gfmrjzzzdb4"))
- (patches (search-patches "upower-builddir.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Upstream commit
- ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
- ;; moved 'dbus-1/system.d' from etc/ to share/. However,
- ;; 'dbus-configuration-directory' in (gnu services dbus)
- ;; expects it in etc/. Thus, move it back to its previous
- ;; location.
- (substitute* "src/Makefile.in"
- (("^dbusconfdir =.*$")
- "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))
- #t))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/upower/upower")
+ (commit (string-append "UPOWER_"
+ (string-map (match-lambda (#\. #\_)
+ (chr chr))
+ version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0frs6ywvsz48d0zfviy40h6mj0icfc1q21hn7p99nchps39z85f8"))
+ (patches (search-patches "upower-builddir.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Upstream commit
+ ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
+ ;; moved 'dbus-1/system.d' from etc/ to share/. However,
+ ;; 'dbus-configuration-directory' in (gnu services dbus)
+ ;; expects it in etc/. Thus, move it back to its previous
+ ;; location.
+ (substitute* "src/Makefile.am"
+ (("^dbusconfdir =.*$")
+ "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))
+ #t))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
@@ -5430,10 +5435,15 @@ faster results and to avoid unnecessary server load.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
("python" ,python)
+ ("which" ,which) ; for ./autogen.sh
;; For tests.
("python-dbus" ,python-dbus)
@@ -5442,9 +5452,9 @@ faster results and to avoid unnecessary server load.")
("umockdev" ,umockdev)
;; For man pages.
- ("libxslt" ,libxslt) ;for 'xsltproc'
- ("libxml2" ,libxml2) ;for 'XML_CATALOG_FILES'
- ("docbook-xsl" ,docbook-xsl)))
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxslt" ,libxslt) ; for 'xsltproc'
+ ("libxml2" ,libxml2))) ; for 'XML_CATALOG_FILES'
(inputs
`(("dbus-glib" ,dbus-glib)
("libgudev" ,libgudev)
diff --git a/gnu/packages/patches/upower-builddir.patch b/gnu/packages/patches/upower-builddir.patch
index 51295f2076..a61d387faf 100644
--- a/gnu/packages/patches/upower-builddir.patch
+++ b/gnu/packages/patches/upower-builddir.patch
@@ -1,3 +1,8 @@
+From 27ae011b31d831752b97eb209bc2b2206fcf40f7 Mon Sep 17 00:00:00 2001
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Mon, 28 Jun 2021 11:58:47 +0200
+Subject: [PATCH] gnu: upower: Fix build directory.
+
Remove explicit set of UPOWER_CONF_FILE_NAME in up-self-test.c;
instead the harness should set it. In Guix we set it explicitly; the
right thing is to use AM_TEST_ENVIRONMENT and regenerate the
@@ -6,13 +11,17 @@ some things, so we patch the Makefile.in instead.
Also fix to not try to create /var/lib/upower if /var isn't writable.
-Patch by Andy Wingo <wingo@igalia.com>
-Reduced to upower 0.99.10 by Tobias Geerinckx-Rice <me@tobias.gr>
+Based on a patch by Andy Wingo <wingo@igalia.com>
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
---- upower-0.99.2.orig/src/Makefile.in 2014-12-18 10:32:01.000000000 +0100
-+++ upower-0.99.2/src/Makefile.in 2015-04-04 19:49:28.020843678 +0200
-@@ -1789,7 +1790,7 @@
- @HAVE_SYSTEMDSYSTEMUNITDIR_TRUE@ @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3400139..f51ee89 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -181,7 +181,7 @@ $(systemdservice_DATA): $(systemdservice_in_files) Makefile
+ endif
install-data-hook:
- if test -w $(DESTDIR)$(prefix)/; then \
@@ -20,3 +29,6 @@ Reduced to upower 0.99.10 by Tobias Geerinckx-Rice <me@tobias.gr>
mkdir -p $(DESTDIR)$(historydir); \
fi
+--
+2.32.0
+