summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-04 13:13:25 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-04 13:14:36 -0400
commit34582b303719bd1f305a2a565285ee19e65a4706 (patch)
tree7803c0c86eb4e9c0e5ba1a5d81def3973fee7251 /gnu
parentdbbc248aeef1bc3b5d76268782acff43e9d71d57 (diff)
downloadguix-patches-34582b303719bd1f305a2a565285ee19e65a4706.tar
guix-patches-34582b303719bd1f305a2a565285ee19e65a4706.tar.gz
gnu: guix: Enable container tests.
* gnu/packages/package-management.scm (guix-devel): Delete 'disable-container-tests' build phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 55e5037aba..f7af1a30da 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -200,18 +200,7 @@ the Nix package manager.")
(chmod po #o666))
(find-files "." "\\.po$"))
- (zero? (system* "sh" "bootstrap"))))
- (add-after
- 'unpack 'disable-container-tests
- ;; XXX FIXME: These tests fail within the build container.
- (lambda _
- (substitute* "tests/syscalls.scm"
- (("^\\(test-assert \"(clone|setns|pivot-root)\"" all)
- (string-append "(test-skip 1)\n" all)))
- (substitute* "tests/containers.scm"
- (("^\\(test-assert" all)
- (string-append "(test-skip 1)\n" all)))
- #t))))))
+ (zero? (system* "sh" "bootstrap"))))))))
(native-inputs
`(("autoconf" ,(autoconf-wrapper))
("automake" ,automake)