summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-25 13:53:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-25 13:55:57 +0200
commit30d6eb85dac539e19994f4637dfc60ecf8826c0b (patch)
tree8a2087e5c8649356b38346ff2811d0778190b8b6 /gnu
parentb3c1dac11b108252491f88c0a2d8a4bde7575b9d (diff)
downloadguix-patches-30d6eb85dac539e19994f4637dfc60ecf8826c0b.tar
guix-patches-30d6eb85dac539e19994f4637dfc60ecf8826c0b.tar.gz
gnu: squeak-vm: Enter build directory once.
* gnu/packages/smalltalk.scm (squeak-vm)[arguments]: Use CHDIR instead of pseudofunctional WITH-DIRECTORY-EXCURSIONs. Drop the custom ‘build’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/smalltalk.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index ea4f8f8db2..5d35f563e2 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -124,23 +124,18 @@ such as ones for networking and GUI programming.")
"unix/cmake/squeak.sh.in")
(("^PATH=.*") ""))
#t))
- (add-after 'unpack 'create-build-dir
+ (add-before 'configure 'enter-build-directory
(lambda _
- (mkdir "bld")
+ (mkdir "build")
+ (chdir "build")
#t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (with-directory-excursion "bld"
- (invoke "../unix/cmake/configure"
- (string-append "--prefix=" out)
- "--without-quartz")
- #t))))
- (replace 'build
- (lambda _
- (with-directory-excursion "bld"
- (invoke "make"))
- #t)))))
+ (invoke "../unix/cmake/configure"
+ (string-append "--prefix=" out)
+ "--without-quartz")
+ #t))))))
(synopsis "Smalltalk programming language and environment")
(description "Squeak is a full-featured implementation of the Smalltalk
programming language and environment based on (and largely compatible with)