summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:10:11 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:16 +0300
commit2f9e1378b60448e455108c03296664820c5e4562 (patch)
tree0bd035b9bbac0a51368a8962aa52185f1a6b7ce5 /gnu
parent192a9a20f0a1c91a5ba8f7791297ce21b99f74f2 (diff)
downloadguix-patches-2f9e1378b60448e455108c03296664820c5e4562.tar
guix-patches-2f9e1378b60448e455108c03296664820c5e4562.tar.gz
gnu: Add emacs-visual-regexp.
* gnu/packages/emacs.scm (emacs-visual-regexp): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0945bf5c1a..843b97d49f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9709,3 +9709,23 @@ interactive behavior should be different.")
(description "This package provides commands for increasing or
decreasing the default font size in all GUI Emacs frames.")
(license license:gpl3+))))
+
+(define-public emacs-visual-regexp
+ (package
+ (name "emacs-visual-regexp")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/benma/visual-regexp.el/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1czmhvcivlcdyz7rfm0vd4a3xsgmy4qbvbl6yjxc217wrxqflr92"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/benma/visual-regexp.el/")
+ (synopsis "Regexp command with interactive visual feedback")
+ (description "This package provides an Emacs regexp command with
+interactive visual feedback.")
+ (license license:gpl3+)))