summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 20:38:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 22:08:24 +0200
commit2f79308872482402d3a32174dbefbf3d6d40f727 (patch)
tree783216e8689cf888def16ce513398694b71b18b8 /gnu
parent3a7504cbc490f74d9b9d0a3a461058c1d6cafbe6 (diff)
downloadguix-patches-2f79308872482402d3a32174dbefbf3d6d40f727.tar
guix-patches-2f79308872482402d3a32174dbefbf3d6d40f727.tar.gz
gnu: Fix ‘this packages’ and some other niggles.
* gnu/packages/crates-io.scm (rust-home-0.5)[description]: Fix ‘this packages’ typo. * gnu/packages/emacs-xyz.scm (emacs-ahg, emacs-cwl-mode)[description]: Likewise. * gnu/packages/python-check.scm (python-pytest-csv)[description]: Likewise. * gnu/packages/ocaml.scm (ocaml-syntax-shims)[description]: Likewise, and note which language. * gnu/packages/python-xyz.scm (python-recommonmark)[description]: Likewise, and work around ‘enabling you’.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm2
-rw-r--r--gnu/packages/emacs-xyz.scm4
-rw-r--r--gnu/packages/ocaml.scm4
-rw-r--r--gnu/packages/python-check.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/web.scm2
6 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 089b9f456c..b8587e8084 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20512,7 +20512,7 @@ IEEE 754-2008 binary16 type.")
(("rust-winapi" ,rust-winapi-0.3))))
(home-page "https://github.com/brson/home")
(synopsis "Shared definitions of home directories")
- (description "This packages provides the definition of @code{home_dir}
+ (description "This package provides the definition of @code{home_dir}
used by @command{cargo} and @command{rustup}, as well as functions to find the
correct value of @samp{CARGO_HOME} and @samp{RUSTUP_HOME}.")
(license (list license:expat license:asl2.0))))
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 31fe24057f..8ad35124ed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1722,7 +1722,7 @@ directly.")
(home-page "https://bitbucket.org/agriggio/ahg")
(synopsis "Emacs front-end for the Mercurial SCM")
(description
- "This packages provides a simple Emacs front-end for the Mercurial
+ "This package provides a simple Emacs front-end for the Mercurial
Distributed @acronym{Source Control Management, SCM} system.")
(license license:gpl3+))))
@@ -29509,7 +29509,7 @@ shorter than usual, using mostly unprefixed keys.")
`(("emacs-yaml-mode" ,emacs-yaml-mode)))
(home-page "https://github.com/tom-tan/cwl-mode")
(synopsis "Emacs mode for @acronym{CWL, Common Workflow Language} files")
- (description "This packages provides a major mode for editing
+ (description "This package provides a major mode for editing
@acronym{CWL, Common Workflow Language} files.")
(license license:gpl3+)))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 025bac691c..660bc44bc7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7262,8 +7262,8 @@ these missing pieces.")
(synopsis
"Backport new syntax to older OCaml versions")
(description
- "This packages backports new features of the language to older
-compilers, such as let+.")
+ "This package backports new language features such as @code{let+} to older
+OCaml compilers.")
(license license:expat)))
(define-public ocaml-angstrom
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f321d0b0f6..a13bd0baa4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -120,7 +120,7 @@ interfaces with pytest.")
("python-six" ,python-six)))
(home-page "https://github.com/nicoulaj/pytest-csv")
(synopsis "CSV reporter for Pytest")
- (description "This packages provides a plugin for Pytest that enables a
+ (description "This package provides a plugin for Pytest that enables a
CSV output mode for Pytest. It can be enabled via the @option{--csv} option
it adds to the Pytest command line interface (CLI).")
(license license:gpl3+)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 18f88fc1a7..eb9fcc310d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27044,8 +27044,8 @@ result.")
(home-page "https://github.com/readthedocs/recommonmark")
(synopsis "Docutils-compatibility bridge to CommonMark")
(description
- "This packages provides a docutils-compatibility bridge to CommonMark,
-enabling you to write CommonMark inside of Docutils & Sphinx projects.")
+ "This package provides a docutils-compatibility bridge to CommonMark that
+lets you write CommonMark inside of Docutils & Sphinx projects.")
(license license:expat)))
(define-public python-pyhull
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0fd9e865cb..7d7a3c4317 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -807,7 +807,7 @@ programming language.")))
;; The nginx source code is part of the module’s source.
(format #t "decompressing nginx source code~%")
(invoke "tar" "xvf" (assoc-ref inputs "nginx-sources")
- ;; This packages's LICENSE file would be
+ ;; This package's LICENSE file would be
;; overwritten with the one from nginx when
;; unpacking the nginx source, so rename the nginx
;; one when unpacking.