summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 02:12:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 03:07:54 +0100
commit2e964d0d7d0f28a183068267a9eda0664f24ceb4 (patch)
treedccbb9c8b357ea7d281ae385c9b11d72fad1a3dd /gnu
parent1bada70d6322f17743b5dadd6b9968c8920038f7 (diff)
downloadguix-patches-2e964d0d7d0f28a183068267a9eda0664f24ceb4.tar
guix-patches-2e964d0d7d0f28a183068267a9eda0664f24ceb4.tar.gz
gnu: agda: Update to 2.6.2.1.
* gnu/packages/agda.scm (agda): Update to 2.6.2.1. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/agda.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 606b0e48b5..4dd6366247 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -37,7 +37,7 @@
(define-public agda
(package
(name "agda")
- (version "2.6.2")
+ (version "2.6.2.1")
(source
(origin
(method url-fetch)
@@ -45,8 +45,7 @@
"https://hackage.haskell.org/package/Agda/Agda-"
version ".tar.gz"))
(sha256
- (base32
- "159hznnsxg7hlp80r1wqizyd7gwgnq0j13cm4d27cns0ganslb07"))))
+ (base32 "03dw7jfqr3ffik6avigm525djqh2gn5c3qwnb2h6298zkr9lch9w"))))
(build-system haskell-build-system)
(inputs
(list ghc-aeson
@@ -81,15 +80,13 @@
;; This allows us to call the 'agda' binary before installing.
(add-after 'unpack 'set-ld-library-path
(lambda _
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))
- #t))
+ (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
(add-after 'compile 'agda-compile
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(agda-compiler (string-append out "/bin/agda")))
(for-each (cut invoke agda-compiler <>)
- (find-files (string-append out "/share") "\\.agda$"))
- #t))))))
+ (find-files (string-append out "/share") "\\.agda$"))))))))
(home-page "https://wiki.portal.chalmers.se/agda/")
(synopsis
"Dependently typed functional programming language and proof assistant")