summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-12-01 00:19:19 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-09 12:02:08 -0600
commit2e66590aad50c6cb6fd39f2d757759874fe19736 (patch)
tree385e3d9cd877a58275da2406a176a4504ef8eabe /gnu
parentc7518b04f0a3487f6c0885779395ed1b1eaffa36 (diff)
downloadguix-patches-2e66590aad50c6cb6fd39f2d757759874fe19736.tar
guix-patches-2e66590aad50c6cb6fd39f2d757759874fe19736.tar.gz
gnu: Add perl-test-script.
* gnu/packages/perl.scm (perl-test-script): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index cdac13dcac..8d25ef3838 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -252,3 +252,27 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
;; "You may use this module under the terms of the BSD, Artistic, or GPL
;; licenses, any version."
(license (list bsd-3 gpl3+))))
+
+(define-public perl-test-script
+ (package
+ (name "perl-test-script")
+ (version "1.07")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ "Test-Script-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15pb4zzsnm33msc1syhig2bk05xqc0pckmfyahdwbd177bj5w7p2"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("probe-perl" ,perl-probe-perl)
+ ("ipc-run3" ,perl-ipc-run3)))
+ (synopsis "Basic cross-platform tests for scripts")
+ (description
+ "The intent of the Test::Script module is to provide a series of basic
+tests for 80% of the testing you will need to do for scripts in the script (or
+bin as is also commonly used) paths of your Perl distribution.")
+ (home-page (string-append "http://search.cpan.org/~adamk/"
+ "Test-Script-" version))
+ (license (package-license perl))))