summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 12:19:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 12:19:03 +0200
commit2b4d43d1c359c5af0839321efaad9324aa4d6edd (patch)
tree697cdff7ca97fc3723fee40ea9d117d5ba4e9dae /gnu
parent146b49d4aa558dda9ffd3a9886977324bacf21e3 (diff)
downloadguix-patches-2b4d43d1c359c5af0839321efaad9324aa4d6edd.tar
guix-patches-2b4d43d1c359c5af0839321efaad9324aa4d6edd.tar.gz
gnu: Add emacs-taxy-magit-section.
* gnu/packages/emacs-xyz.scm (emacs-taxy-magit-section): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 797a18c496..e613f02d55 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16613,6 +16613,29 @@ a hierarchical taxonomy. Allows you to automatically put things in nested
groups.")
(license license:gpl3+)))
+(define-public emacs-taxy-magit-section
+ (package
+ (name "emacs-taxy-magit-section")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/taxy-magit-section-" version
+ ".tar"))
+ (sha256
+ (base32
+ "0ybkz5nqjdrg2z9bfd07xg4k49hrl26vsrwz2vqpfbsqqg5vr4pr"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-magit emacs-taxy))
+ (home-page "https://github.com/alphapapa/taxy.el")
+ (synopsis "View Taxy structs in a Magit Section buffer")
+ (description
+ "This library provides a way to view @code{taxy} structs in a column-based,
+@code{magit-section} buffer. Columns are defined using simple top-level
+forms, and new columns may be easily defined by users in their
+configurations.")
+ (license license:gpl3+)))
+
(define-public emacs-emojify
(package
(name "emacs-emojify")