summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:31:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:46 +0200
commit28f9cab0de5f3bfdaf3823e4fb8eef97d3711939 (patch)
treeeccab68ec5b832075e77e4b2f1035c04df40fa9c /gnu
parentfc15796398040f8847c8869292882d171bd2fe8d (diff)
downloadguix-patches-28f9cab0de5f3bfdaf3823e4fb8eef97d3711939.tar
guix-patches-28f9cab0de5f3bfdaf3823e4fb8eef97d3711939.tar.gz
gnu: Add texlive-collection-metapost.
* gnu/packages/tex.scm (texlive-collection-metapost): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 53cacc867e..3e25129621 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13296,6 +13296,68 @@ used and strongly recommended in practice.")
LaTeX which have widespread use.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-metapost
+ (package
+ (name "texlive-collection-metapost")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-automata
+ texlive-bbcard
+ texlive-blockdraw-mp
+ texlive-bpolynomial
+ texlive-cmarrows
+ texlive-collection-basic
+ texlive-drv
+ texlive-dviincl
+ texlive-emp
+ texlive-epsincl
+ texlive-expressg
+ texlive-exteps
+ texlive-featpost
+ texlive-feynmf
+ texlive-feynmp-auto
+ texlive-fiziko
+ texlive-garrigues
+ texlive-gmp
+ texlive-hatching
+ texlive-hershey-mp
+ texlive-latexmp
+ texlive-mcf2graph
+ texlive-metago
+ texlive-metaobj
+ texlive-metaplot
+ texlive-metapost
+ texlive-metapost-colorbrewer
+ texlive-metauml
+ texlive-mfpic
+ texlive-mfpic4ode
+ texlive-minim-hatching
+ texlive-mp3d
+ texlive-mparrows
+ texlive-mpattern
+ texlive-mpcolornames
+ texlive-mpgraphics
+ texlive-mptrees
+ texlive-piechartmp
+ texlive-repere
+ texlive-roex
+ texlive-roundrect
+ texlive-shapes
+ texlive-slideshow
+ texlive-splines
+ texlive-suanpan
+ texlive-textpath
+ texlive-threeddice))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "MetaPost and Metafont packages")
+ (description
+ "This collection includes all MetaPost and Metafont packages, along
+with packages in @code{collection-basic}.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-grfext
(package
(name "texlive-grfext")