summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:00:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:26 +0300
commit28afc9baadd72a03faa30b7d7f6d439de41730c5 (patch)
tree49f201e0c4e218652a2a89de205a5e62a08893a4 /gnu
parent6496b31a66b5665c55ec11a14e73f278d34f8a35 (diff)
downloadguix-patches-28afc9baadd72a03faa30b7d7f6d439de41730c5.tar
guix-patches-28afc9baadd72a03faa30b7d7f6d439de41730c5.tar.gz
gnu: Add julia-recipesbase.
* gnu/packages/julia-xyz.scm (julia-recipesbase): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 21d2f4de2e..38a82c7de2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1442,6 +1442,30 @@ algorithms, while ensuring that the most efficient implementation is used in
actual computation.")
(license license:expat)))
+(define-public julia-recipesbase
+ (package
+ (name "julia-recipesbase")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaPlots/RecipesBase.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b6m5rz6wprj30rwvlxz4r1jv5gl0ay0f52kfmy2w7lqly7zhap5"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaPlots/RecipesBase.jl")
+ (synopsis "Define transformation recipes on user types")
+ (description "This package implements handy macros @code{@@recipe} and
+@code{@@series} which will define a custom transformation and attach attributes
+for user types. Its design is an attempt to simplify and generalize the summary
+and display of types and data from external packages. With this package it is
+possible to describe visualization routines that can be used as components in
+more complex visualizations.")
+ (license license:expat)))
+
(define-public julia-reexport
(package
(name "julia-reexport")