summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 00:40:37 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 21:08:34 +0200
commit271f27864096728ebd05b61d2015ef3fade1dde6 (patch)
treed1453f64fa68d5d882f6b990749498c7cff53029 /gnu
parente85d7ed60905f059686650c3ab21b42500f09351 (diff)
downloadguix-patches-271f27864096728ebd05b61d2015ef3fade1dde6.tar
guix-patches-271f27864096728ebd05b61d2015ef3fade1dde6.tar.gz
gnu: LibRaw: Update to 0.20.0 [fixes CVE-2020-15503].
* gnu/packages/photo.scm (libraw): Update to 0.20.0. * gnu/packages/image.scm (freeimage)[source](patches): Add LibRaw compatibility patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm14
-rw-r--r--gnu/packages/photo.scm4
2 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3fdc6db8a1..c6af458286 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1030,7 +1030,19 @@ supplies a generic doubly-linked list and some string functions.")
(delete-file-recursively (string-append "Source/" dir)))
'("LibJPEG" "LibOpenJPEG" "LibPNG" "LibRawLite"
"LibJXR" "LibWebP" "OpenEXR" "ZLib"))))
- (patches (search-patches "freeimage-unbundle.patch"))))
+ (patches
+ (append
+ (search-patches "freeimage-unbundle.patch")
+ ;; Take one patch from Arch Linux that adds LibRaw 0.20 compatibility.
+ (list (origin
+ (method url-fetch)
+ (uri "https://raw.githubusercontent.com/archlinux\
+/svntogit-community/ca3e6a52f5a46dec87cbf85e9d84fe370e282c8c/trunk\
+/freeimage-libraw-0.20.patch")
+ (file-name "freeimage-libraw-compat.patch")
+ (sha256
+ (base32
+ "0cwjxjz0f4gs6igvwqg0p99mnrsrwzkal1l2n08yvz2xq9s5khki"))))))))
(build-system gnu-build-system)
(arguments
'(#:phases
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 09767f464e..abdb751a5a 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -173,14 +173,14 @@ cards and generate meaningful file and folder names.")
(define-public libraw
(package
(name "libraw")
- (version "0.19.5")
+ (version "0.20.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.libraw.org/data/LibRaw-"
version ".tar.gz"))
(sha256
(base32
- "1x827sh6vl8j3ll2ihkcr234y07f31hi1v7sl08jfw3irkbn58j0"))))
+ "18wlsvj6c1rv036ph3695kknpgzc3lk2ikgshy8417yfl8ykh2hz"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))