summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMasaya Tojo <masaya@tojo.tokyo>2022-09-06 17:00:34 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-06 13:46:27 +0200
commit26ac47d96b49621245ee77a0a882e22cd5b2d6dd (patch)
tree519d5b9a88ca79686507aa26445c40c8b0370e93 /gnu
parentdac4fd03cf9dbace17e3f58aed01ab15a4d3bf18 (diff)
downloadguix-patches-26ac47d96b49621245ee77a0a882e22cd5b2d6dd.tar
guix-patches-26ac47d96b49621245ee77a0a882e22cd5b2d6dd.tar.gz
gnu: Add emacs-ox-rss.
* gnu/packages/emacs-xyz.scm (emacs-ox-rss): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2f41654777..2f4bfd69e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -61,7 +61,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021 Masaya Tojo <masaya@tojo.tokyo>
+;;; Copyright © 2020, 2021, 2022 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020, 2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
@@ -28042,6 +28042,30 @@ With org-reveal, you can create beautiful presentations with 3D effects from
simple but powerful Org contents.")
(license license:gpl3+))))
+(define-public emacs-ox-rss
+ ;; XXX: Upstream provides no version nor tags whatsoever.
+ (let ((commit "83dc898fa5493925b01716e5dd495d5e07c3d41a")
+ (revision "0"))
+ (package
+ (name "emacs-ox-rss")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/nsavage/ox-rss")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0513kixv9bgkignmji95m3rskn6px6c0fack4zdl61qq09fg8w6h"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/nsavage/ox-rss")
+ (synopsis "RSS 2.0 back-end for Org export engine")
+ (description
+ "This library implements an RSS 2.0 back-end for Org exporter, based
+on the HTML back-end.")
+ (license license:gpl3+))))
+
(define-public emacs-wc-mode
(package
(name "emacs-wc-mode")