summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:14 +0100
commit24ce64216e1f03c14c1693cb9d1051691b758b1f (patch)
tree257fd133c66c6d9a39ab1b1a96373a172277138d /gnu
parent5d0f33c2ab9aa0cdc51a35525e895a603eac78ea (diff)
downloadguix-patches-24ce64216e1f03c14c1693cb9d1051691b758b1f.tar
guix-patches-24ce64216e1f03c14c1693cb9d1051691b758b1f.tar.gz
gnu: python-h5py: Update to 2.10.0.
* gnu/packages/python-xyz.scm (python-h5py): Update to 2.10.0. [inputs]: Use hdf5-1.10. [native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3cd1686d28..7003f60b15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -475,14 +475,14 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(define-public python-h5py
(package
(name "python-h5py")
- (version "2.8.0")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h5py" version))
(sha256
(base32
- "0mdr6wrq02ac93m1aqx9kad0ppfzmm4imlxqgyy1x4l7hmdcc9p6"))))
+ "0baipzv8n93m0dq0riyi8rfhzrjrfrfh8zqhszzp1j2xjac2fhc4"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -504,10 +504,11 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
`(("python-six" ,python-six)
("python-numpy" ,python-numpy)))
(inputs
- `(("hdf5" ,hdf5)))
+ `(("hdf5" ,hdf5-1.10)))
(native-inputs
`(("python-cython" ,python-cython)
- ("python-pkgconfig" ,python-pkgconfig)))
+ ("python-pkgconfig" ,python-pkgconfig)
+ ("pkg-config" ,pkg-config)))
(home-page "https://www.h5py.org/")
(synopsis "Read and write HDF5 files from Python")
(description