summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2021-02-08 16:40:17 +0100
committerLeo Famulari <leo@famulari.name>2021-02-09 14:53:01 -0500
commit1e9f667708ba6fdc4b16fe6851bc0ea0b6306fad (patch)
treed7b231ecbb8f3b028feb7d46554f7ae1a410deba /gnu
parente6034e3cf8d662d35b5de903b93916e2d2292e0d (diff)
downloadguix-patches-1e9f667708ba6fdc4b16fe6851bc0ea0b6306fad.tar
guix-patches-1e9f667708ba6fdc4b16fe6851bc0ea0b6306fad.tar.gz
gnu: qpdfview: Fix qt-5.15 compatibility.
* gnu/packages/pdf.scm (qpdfview)[source]: Add patch to include a missing header. * gnu/packages/patches/qpdfview-qt515-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qpdfview-qt515-compat.patch17
-rw-r--r--gnu/packages/pdf.scm3
3 files changed, 20 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7b6cd8e0ae..886c8531c9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1560,6 +1560,7 @@ dist_patch_DATA = \
%D%/packages/patches/pypy3-7.3.1-fix-tests.patch \
%D%/packages/patches/qemu-build-info-manual.patch \
%D%/packages/patches/qemu-glibc-2.27.patch \
+ %D%/packages/patches/qpdfview-qt515-compat.patch \
%D%/packages/patches/qrcodegen-cpp-make-install.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-absolute-runpath.patch \
diff --git a/gnu/packages/patches/qpdfview-qt515-compat.patch b/gnu/packages/patches/qpdfview-qt515-compat.patch
new file mode 100644
index 0000000000..1fbf5ec3f1
--- /dev/null
+++ b/gnu/packages/patches/qpdfview-qt515-compat.patch
@@ -0,0 +1,17 @@
+Fix compatibility with Qt 5.15.
+
+Patch copied from upstream source repository:
+
+https://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/revision/2104
+
+--- a/sources/model.h 2017-04-19 21:01:25 +0000
++++ b/sources/model.h 2020-06-09 06:24:11 +0000
+@@ -24,6 +24,7 @@
+ #define DOCUMENTMODEL_H
+
+ #include <QList>
++#include <QPainterPath>
+ #include <QtPlugin>
+ #include <QWidget>
+ #include <QVector>
+
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66e920a7bb..3063aa10c0 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -869,7 +869,8 @@ program capable of converting PDF into other formats.")
"trunk/" version "/+download/"
"qpdfview-" version ".tar.gz"))
(sha256
- (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))))
+ (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))
+ (patches (search-patches "qpdfview-qt515-compat.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))