summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-05-20 22:20:01 -0500
committerEric Bavier <bavier@member.fsf.org>2021-05-20 22:20:01 -0500
commit1a06cafc07b5ab6a46ea174937694fe8df7fd24a (patch)
tree5e01ec3f7d21889f854256882caf22f6954c79de /gnu
parentf7d2ae57543ae6afe14434877d7480b15dcbb5b7 (diff)
downloadguix-patches-1a06cafc07b5ab6a46ea174937694fe8df7fd24a.tar
guix-patches-1a06cafc07b5ab6a46ea174937694fe8df7fd24a.tar.gz
gnu: detox: Update to 1.4.2.
* gnu/packages/admin.scm (detox): Update to 1.4.2 [arguments]: Remove '#:tests?', provide customer 'check' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b49b952201..001c6db414 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015, 2016, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2020, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2015, 2016 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -2137,7 +2137,7 @@ system is under heavy load.")
(define-public detox
(package
(name "detox")
- (version "1.3.3")
+ (version "1.4.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2146,21 +2146,23 @@ system is under heavy load.")
(file-name (git-file-name name version))
(sha256
(base32
- "13mhs62m7bpff45liy65pajq5jg3i12jj90vwdkra94z9mlr2rlz"))))
+ "0q16dvjbry573j4ayh9dwskdh1dxx8dk4rj94w6f2dcv4ww37is1"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("flex" ,flex)))
(arguments
- `(#:tests? #f ;no 'check' target
- #:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-after 'unpack 'delete-configure
;; The "configure" script is present, but otherwise the
;; project is not bootstrapped: missing install-sh and
;; Makefile.in, so delete it so the bootstrap phase will
;; take over.
- (lambda _ (delete-file "configure") #t)))))
+ (lambda _ (delete-file "configure") #t))
+ (replace 'check
+ (lambda _
+ (invoke "./tests/test.sh" "src/detox"))))))
(home-page "https://github.com/dharple/detox")
(synopsis "Clean up file names")
(description