summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-08-03 13:52:13 +0200
committerLeo Famulari <leo@famulari.name>2018-08-13 11:43:04 -0400
commit18e56ad7eba42b23e338dfc77cd057bf8a076f19 (patch)
tree3c2110c53d7354a36e7c0d1f2da17e4578d23a45 /gnu
parent504e26ed3238487adc62772798df6d41fc13668e (diff)
downloadguix-patches-18e56ad7eba42b23e338dfc77cd057bf8a076f19.tar
guix-patches-18e56ad7eba42b23e338dfc77cd057bf8a076f19.tar.gz
gnu: aegisub: Fix build.
* gnu/packages/patches/aegisub-icu59-include-unistr.patch: New file. * gnu/lokal.mk (dist_patch_DATA): Register it. * gnu/packages/video.scm (aegisub)[source]: Use patch. [arguments]: Add CXXFLAGS, Return #t from fix-ldflags phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/aegisub-icu59-include-unistr.patch12
-rw-r--r--gnu/packages/video.scm10
3 files changed, 20 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index dee36f8b44..53120db7f7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -566,6 +566,7 @@ dist_patch_DATA = \
%D%/packages/patches/aegis-perl-tempdir2.patch \
%D%/packages/patches/aegis-test-fixup-1.patch \
%D%/packages/patches/aegis-test-fixup-2.patch \
+ %D%/packages/patches/aegisub-icu59-include-unistr.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/amule-crypto-6.patch \
%D%/packages/patches/ansible-wrap-program-hack.patch \
diff --git a/gnu/packages/patches/aegisub-icu59-include-unistr.patch b/gnu/packages/patches/aegisub-icu59-include-unistr.patch
new file mode 100644
index 0000000000..78414741be
--- /dev/null
+++ b/gnu/packages/patches/aegisub-icu59-include-unistr.patch
@@ -0,0 +1,12 @@
+This patch adds an include needed since icu59:
+Source: https://git.archlinux.org/svntogit/community.git/plain/trunk/icu59.patch?h=packages/aegisub
+--- aegisub-3.2.2/src/utils.cpp 2014-12-08 02:07:09.000000000 +0200
++++ aegisub-3.2.2/src/utils.cpp 2017-04-26 11:11:15.438239182 +0300
+@@ -44,6 +44,7 @@
+ #include <boost/filesystem/path.hpp>
+ #include <map>
+ #include <unicode/locid.h>
++#include <unicode/unistr.h>
+ #include <wx/clipbrd.h>
+ #include <wx/filedlg.h>
+ #include <wx/stdpaths.h>
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2a1391c049..510122ab3b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2738,21 +2739,24 @@ programmers to access a standard API to open and decompress media files.")
name "-" version ".tar.xz"))
(sha256
(base32
- "11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))))
+ "11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))
+ (patches (search-patches "aegisub-icu59-include-unistr.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list "--disable-update-checker"
"--without-portaudio"
"--without-openal"
- "--without-oss")
+ "--without-oss"
+ "CXXFLAGS=-DU_USING_ICU_NAMESPACE=1")
;; tests require busted, a lua package we don't have yet
#:tests? #f
#:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-ldflags
(lambda _
- (setenv "LDFLAGS" "-pthread"))))))
+ (setenv "LDFLAGS" "-pthread")
+ #t)))))
(inputs
`(("boost" ,boost)
("desktop-file-utils" ,desktop-file-utils)