summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-12-03 09:46:41 +0100
committerJohn Darrington <jmd@gnu.org>2014-12-03 11:14:57 +0100
commit1567bb197698da49f6aad5db8394636e8f60c173 (patch)
treeb53b197c96ba00471625bab7e022e4191e67cea9 /gnu
parenta7f862e4dade6942bb67322a97d733e7f89f564f (diff)
downloadguix-patches-1567bb197698da49f6aad5db8394636e8f60c173.tar
guix-patches-1567bb197698da49f6aad5db8394636e8f60c173.tar.gz
gnu: Add tre (including the agrep utility)
* gnu/packages/tre.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tre.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/tre.scm b/gnu/packages/tre.scm
new file mode 100644
index 0000000000..33d2cff093
--- /dev/null
+++ b/gnu/packages/tre.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright 2014 John Darrington
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tre)
+ #:use-module (gnu packages)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses))
+
+(define-public tre
+ (package
+ (name "tre")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://laurikari.net/tre/" name "-" version
+ ".tar.bz2"))
+ (sha256
+ (base32 "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
+
+ (build-system gnu-build-system)
+ (synopsis "Approximate regex matching library and agrep utility")
+ (description "Superset of the POSIX regex API, enabling approximate
+matching. Also ships a version of the agrep utility which behaves similar to
+grep but features ineaxct matching.")
+ (home-page "http://laurikari.net/tre")
+ (license bsd-2)))