summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-30 16:36:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 22:01:43 +0100
commit1331a6c07af80ac01c9d4a28df2dd024d9de1c54 (patch)
tree81df5f9113c759bfdcf7e29f5a43f0dee32b0505 /gnu
parent84243592fe267e12a32151f10618b4a52c0d43be (diff)
downloadguix-patches-1331a6c07af80ac01c9d4a28df2dd024d9de1c54.tar
guix-patches-1331a6c07af80ac01c9d4a28df2dd024d9de1c54.tar.gz
gnu: Add python-discid.
* gnu/packages/music.scm (python-discid): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4943b901e1..cb625b2493 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4076,6 +4077,42 @@ it provides a submission URL for adding the disc ID to the database and gathers
ISRCs and the MCN (=UPC/EAN) from disc.")
(license license:lgpl2.1+)))
+(define-public python-discid
+ (package
+ (name "python-discid")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "discid" version))
+ (sha256
+ (base32
+ "1fgp67nhqlbvhhwrcxq5avil7alpzw4s4579hlyvxzbphdnbz8vq"))))
+ (build-system python-build-system)
+ (inputs
+ `(("libdiscid" ,libdiscid)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-libdiscid
+ ;; Set path of libdiscid
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((discid (assoc-ref inputs "libdiscid")))
+ (substitute* "discid/libdiscid.py"
+ (("lib_name = (.*)$" all name)
+ (string-append "lib_name = \"" discid
+ "/lib/libdiscid.so.0\"\n")))
+ #t))))))
+ (home-page "https://python-discid.readthedocs.io/")
+ (synopsis "Python bindings for Libdiscid")
+ (description
+ "This package provides Python bindings for the Libdiscid library. The
+main purpose is the calculation of @url{https://musicbrainz.org/doc/Disc%20ID,
+Disc IDs} for use with the MusicBrainz database. Additionally the disc
+@dfn{Media Catalog Number} (MCN) and track @dfn{International Standard
+Recording Code} (ISRC) can be extracted.}")
+ (license license:lgpl3+)))
+
(define-public libmusicbrainz
(package
(name "libmusicbrainz")