summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-29 15:48:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-29 16:16:43 +0200
commit130f4070d769a0fb375758ab0dadb5572447d5f7 (patch)
treec7d3776fedc0023ac1376b33b402a233c74696a4 /gnu
parent20f0027325f85ac47ebfef635d8944dea440fb90 (diff)
downloadguix-patches-130f4070d769a0fb375758ab0dadb5572447d5f7.tar
guix-patches-130f4070d769a0fb375758ab0dadb5572447d5f7.tar.gz
gnu: emacs-minitest: Update to 0.9.2.
* gnu/packages/emacs-xyz.scm (emacs-minitest): Update to 0.9.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 121bd94e66..8398cb2769 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3923,36 +3923,34 @@ of files under Git version control from within Emacs.")
(license license:gpl3+)))
(define-public emacs-minitest
- (let ((commit "1aadb7865c1dc69c201cecee275751ecec33a182")
- (revision "1"))
- (package
- (name "emacs-minitest")
- (version (git-version "0.8.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/arthurnn/minitest-emacs")
- (commit commit)))
- (file-name (git-file-name name commit))
- (sha256
- (base32
- "1l18zqpdzbnqj2qawq8hj7z7pl8hr8z9d8ihy8jaiqma915hmhj1"))))
- (build-system emacs-build-system)
- (arguments
- '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
- #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-f" ,emacs-f)))
- (home-page "https://github.com/arthurnn/minitest-emacs")
- (synopsis "Emacs minitest mode")
- (description
- "The minitest mode provides commands to run the tests for the current
+ (package
+ (name "emacs-minitest")
+ (version "0.9.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arthurnn/minitest-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d8kg68yy5x1y3ivj43vzcakb3gii6bh8jm40g4sah5f53bbrs16"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/arthurnn/minitest-emacs")
+ (synopsis "Emacs minitest mode")
+ (description
+ "The minitest mode provides commands to run the tests for the current
file or line, as well as rerunning the previous tests, or all the tests for a
project.
This package also includes relevant snippets for yasnippet.")
- (license license:expat))))
+ (license license:expat)))
(define-public emacs-gdscript-mode
(package