summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-25 20:57:14 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-25 20:57:14 +0200
commit0de71c233cb1d4fdea1d41bfe8a39be778502d81 (patch)
tree20f1d007484a58dbb761519480e87ce9cacbfa49 /gnu
parent7e873a6708779481e2c2baa82ddbd8fcf232db5f (diff)
downloadguix-patches-0de71c233cb1d4fdea1d41bfe8a39be778502d81.tar
guix-patches-0de71c233cb1d4fdea1d41bfe8a39be778502d81.tar.gz
gnu: cross-base: Make the cross tools native inputs.
* gnu/packages/cross-base.scm (cross-gcc): Change `inputs' to `native-inputs', and set `inputs' to the empty list. (cross-libc): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cross-base.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 5c46d00b20..4cfbbba234 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -175,7 +175,8 @@ GCC that does not target a libc; otherwise, target that libc."
;; <http://lists.fedoraproject.org/pipermail/arm/2010-August/000663.html>
;; for instance.
#f))))
- (inputs
+
+ (native-inputs
`(("patch/cross-env-vars"
,(search-patch "gcc-cross-environment-variables.patch"))
@@ -193,6 +194,8 @@ GCC that does not target a libc; otherwise, target that libc."
,@inputs)
inputs))))
+ (inputs '())
+
;; Only search target inputs, not host inputs.
(search-paths
(list (search-path-specification
@@ -225,9 +228,9 @@ XBINUTILS and the cross tool chain."
(and (zero? (system* "make" "defconfig"))
(zero? (system* "make" "mrproper" "headers_check"))))
,phases))))
- (inputs `(("cross-gcc" ,xgcc)
- ("cross-binutils" ,xbinutils)
- ,@(package-inputs linux-libre-headers)))))
+ (native-inputs `(("cross-gcc" ,xgcc)
+ ("cross-binutils" ,xbinutils)
+ ,@(package-native-inputs linux-libre-headers)))))
(package (inherit glibc)
(name (string-append "glibc-cross-" target))
@@ -248,9 +251,9 @@ XBINUTILS and the cross tool chain."
#t))
,phases))))
(propagated-inputs `(("cross-linux-headers" ,xlinux-headers)))
- (inputs `(("cross-gcc" ,xgcc)
- ("cross-binutils" ,xbinutils)
- ,@(package-inputs glibc)))))
+ (native-inputs `(("cross-gcc" ,xgcc)
+ ("cross-binutils" ,xbinutils)
+ ,@(package-native-inputs glibc)))))
;;;