summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-30 10:22:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-03-30 10:35:53 +0200
commit0d2c0562b86c70e409df53b6013d2835781a673b (patch)
tree77f4f2d32e55a256e3d86c8ecc8ec7bfe2d6679c /gnu
parentc3913fac57c557ba5ebc98c646f75c7000ab8aa7 (diff)
downloadguix-patches-0d2c0562b86c70e409df53b6013d2835781a673b.tar
guix-patches-0d2c0562b86c70e409df53b6013d2835781a673b.tar.gz
gnu: stringtie: Remove typedef conflict.
* gnu/packages/bioinformatics.scm (stringtie)[arguments]: Remove conflicting typedef in a new build phase "remove-duplicate-typedef".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 232c7db838..1bba270749 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5210,6 +5210,13 @@ against local background noises.")
(("#include \"(bam|sam|kstring).h\"" _ header)
(string-append "#include <samtools/" header ".h>")))
#t))
+ (add-after 'unpack 'remove-duplicate-typedef
+ (lambda _
+ ;; This typedef conflicts with the typedef in
+ ;; glibc-2.25/include/bits/types.h
+ (substitute* "gclib/GThreads.h"
+ (("typedef long long __intmax_t;") ""))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))