summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCairn <cairn@pm.me>2022-08-28 04:56:39 +0000
committerLudovic Courtès <ludo@gnu.org>2022-09-06 16:58:12 +0200
commit0c5e2333ca84122e7c3bc037239bde41ebc98c8d (patch)
tree25dde7a64e9e185b4cd49df7bd224741a8631bc6 /gnu
parentdddc68350de0d4904e04504fd4a758119c0d56bd (diff)
downloadguix-patches-0c5e2333ca84122e7c3bc037239bde41ebc98c8d.tar
guix-patches-0c5e2333ca84122e7c3bc037239bde41ebc98c8d.tar.gz
gnu: Add pixterm.
* gnu/packages/image-viewers.scm (pixterm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-viewers.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 23175472ef..ff880ef79d 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
@@ -73,6 +75,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
@@ -510,6 +513,35 @@ your images. Among its features are:
It supports JPEG, PNG and GIF formats.")
(license license:expat)))
+(define-public pixterm
+ (package
+ (name "pixterm")
+ (version "1.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eliukblau/pixterm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fm6c0mjz6zillqjirnjjf7mkrax1gyfcv6777i07ms3bnv0pcii"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/eliukblau/pixterm/cmd/pixterm"
+ #:unpack-path "github.com/eliukblau/pixterm"))
+ (inputs (list go-github-com-disintegration-imaging
+ go-golang-org-colorful
+ go-golang-org-x-crypto
+ go-golang-org-x-image))
+ (home-page "https://github.com/eliukblau/pixterm")
+ (synopsis "Draw images in your ANSI terminal with true color")
+ (description "PIXterm shows images directly in your terminal, recreating
+the pixels through a combination of ANSI character background color and the
+unicode lower half block element. It supports JPEG, PNG, GIF, BMP, TIFF
+and WebP.")
+ (license license:mpl2.0)))
+
(define-public luminance-hdr
(package
(name "luminance-hdr")