summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-06 12:34:39 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-06 12:38:03 +0100
commit072fd1124a8081753ce92ed3a2a57489d24c5e4a (patch)
tree1b64082926a371f5474e1469d87a0f3f5b0df941 /gnu
parent7138ba34fa11d3eb2d9e7e44771e698f53415dbc (diff)
downloadguix-patches-072fd1124a8081753ce92ed3a2a57489d24c5e4a.tar
guix-patches-072fd1124a8081753ce92ed3a2a57489d24c5e4a.tar.gz
gnu: shepherd@0.9: Use 'guile-3.0-latest' to address memory leak.
Fixes <https://issues.guix.gnu.org/58631>. Previously, shepherd's heap would grow roughly linearly in the number of context switches (delimited continuations being captured). For example, if shepherd spawned services that logged a lot of data, it would context-switch a lot, leading to relatively quick heap growth. * gnu/packages/admin.scm (shepherd-0.9)[inputs, native-inputs]: Replace 'guile-3.0' with 'guile-3.0-latest'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5576c3da77..273dffbc18 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -368,9 +368,12 @@ interface and is based on GNU Guile.")
(this-package-input "guile-fibers")
"/lib/guile/3.0/site-ccache"))))))
#~%standard-phases)))
- (native-inputs (list pkg-config guile-3.0
+
+ ;; Note: Use 'guile-3.0-latest' to address the continuation-related memory
+ ;; leak reported at <https://issues.guix.gnu.org/58631>.
+ (native-inputs (list pkg-config guile-3.0-latest
guile-fibers-1.1)) ;for cross-compilation
- (inputs (list guile-3.0 guile-fibers-1.1))))
+ (inputs (list guile-3.0-latest guile-fibers-1.1))))
(define-public guile2.2-shepherd
(package