summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-08-02 22:03:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-25 12:24:24 +0200
commit05f2938f04414ba57909f1cdb8b6eadcf9ac4cd6 (patch)
tree57aef3da78de7de268ff45ad67b623601e53998e /gnu
parent59d52f6d434ed9e68e31c03d246609307f20dec5 (diff)
downloadguix-patches-05f2938f04414ba57909f1cdb8b6eadcf9ac4cd6.tar
guix-patches-05f2938f04414ba57909f1cdb8b6eadcf9ac4cd6.tar.gz
gnu: Add emacs-super-save.
* gnu/packages/emacs-xyz.scm (emacs-super-save): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5870c9efa..5d90b78208 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28064,6 +28064,29 @@ It can also be useful on Unix-like platforms to delay having to enter your
passphrase until the first time you push to a remote.")
(license license:gpl3+)))
+(define-public emacs-super-save
+ (package
+ (name "emacs-super-save")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bbatsov/super-save")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "066fyg4r4pksyandpd7s53hagpvm2rw90q5ks4jlpgy7x00hw09l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bbatsov/super-save")
+ (synopsis "Auto-save buffers, based on your activity")
+ (description "Super-save auto-saves your buffers, when certain events
+happen, e.g., when you switch between buffers or when an Emacs frame loses
+focus. You can think of it as both something that augments and replaces the
+standard Auto-save mode.")
+ (license license:gpl3+)))
+
(define-public emacs-tao-theme
(let ((commit "468ee4f6ba7afb9dbfc8855ae2c333cb16ca4408")
(revision "1"))