summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 18:03:22 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 18:37:50 +0100
commit0154fac42a6e3ec6080605af89958b779f536e9d (patch)
tree930c017ab4a66f81fc7bea4612c9f4652c9a1649 /gnu
parent48d38125c20daa7d89f25245e4463df41e6c957f (diff)
downloadguix-patches-0154fac42a6e3ec6080605af89958b779f536e9d.tar
guix-patches-0154fac42a6e3ec6080605af89958b779f536e9d.tar.gz
gnu: ghc: Depend on 'git-minimal/fixed'.
* gnu/packages/haskell.scm (ghc-8.8): Replace GIT/FIXED by GIT-MINIMAL/FIXED. * gnu/packages/version-control.scm (git/fixed): Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm3
-rw-r--r--gnu/packages/version-control.scm26
2 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 84a9075453..69a806e635 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -634,8 +634,7 @@ interactive environment for the functional language Haskell.")
(sha256
(base32
"0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
- ;; TODO: Change to GIT-MINIMAL/FIXED.
- ("git" ,git/fixed) ; invoked during tests
+ ("git" ,git-minimal/fixed) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index da03aef7c7..b8f99f1885 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -669,32 +669,6 @@ everything from small to very large projects with speed and efficiency.")
(base32
"0bqz401dyp8wnjj3k5ahrniwk4dalndysqazzwdvv25hqbkacm70"))))))
-(define-public git/fixed
- ;; Version that rarely changes, depended on by GHC.
- ;; TODO: Remove and use 'git-minimal/fixed' instead.
- (package/inherit git
- (version "2.33.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://kernel.org/software/scm/git/git-"
- version ".tar.xz"))
- (sha256
- (base32
- "0bqz401dyp8wnjj3k5ahrniwk4dalndysqazzwdvv25hqbkacm70"))))
- (properties `((hidden? . #t)
- ,@(package-properties git)))
- (native-inputs
- (modify-inputs (package-native-inputs git)
- (replace "git-manpages"
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kernel.org/software/scm/git/git-manpages-"
- version ".tar.xz"))
- (sha256
- (base32
- "11xb0n1ckkm2g7r3sxsknkhsak739xg925zbz3aalv7mr7qijln7"))))))))
-
(define-public git2cl
(let ((commit "1d74d4c0d933fc69ed5cec838c73502584dead05"))
(package