summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-27 17:53:42 -0400
committerLeo Famulari <leo@famulari.name>2017-07-30 20:10:40 -0400
commit00ace8839690e56e9095969cf7c21f288322072e (patch)
tree2fb9e3cffaadafcbaec97a1c81cb05371ea453bc /gnu
parenta4d6a95793b2c98fb11908d6dec85532d6df5613 (diff)
downloadguix-patches-00ace8839690e56e9095969cf7c21f288322072e.tar
guix-patches-00ace8839690e56e9095969cf7c21f288322072e.tar.gz
gnu: Add perl-test-file-sharedir-dist.
* gnu/packages/perl.scm (perl-test-file-sharedir-dist): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 26ff0458fb..714c111392 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6762,6 +6762,32 @@ Test::Exception. It does much less, but should allow greater flexibility in
testing exception-throwing code with about the same amount of typing.")
(license (package-license perl))))
+(define-public perl-test-file-sharedir-dist
+ (package
+ (name "perl-test-file-sharedir-dist")
+ (version "1.001002")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/K/KE/KENTNL/"
+ "Test-File-ShareDir-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bbs6cx69wcinq77gif4i4pmrj8a7lwb92sgvvxzrwmjnk5lfdmk"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-class-tiny" ,perl-class-tiny)
+ ("perl-file-copy-recursive" ,perl-file-copy-recursive)
+ ("perl-file-sharedir" ,perl-file-sharedir)
+ ("perl-path-tiny" ,perl-path-tiny)
+ ("perl-scope-guard" ,perl-scope-guard)
+ ("perl-test-fatal" ,perl-test-fatal)))
+ (home-page "https://github.com/kentnl/Test-File-ShareDir")
+ (synopsis "Dist oriented ShareDir tester")
+ (description "This module creates a Fake ShareDir for your modules
+for testing.")
+ (license (package-license perl))))
+
(define-public perl-test-files
(package
(name "perl-test-files")