summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-06-26 10:16:32 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:53 +0200
commit001504a70ab8e34742aea3fe9e21619a7264dc25 (patch)
tree6d850685fd9bd8efadc5bd67234f69a4e6eb56d1 /gnu
parent567cca260d54a4515097ff3f2dc277d10ceaf613 (diff)
downloadguix-patches-001504a70ab8e34742aea3fe9e21619a7264dc25.tar
guix-patches-001504a70ab8e34742aea3fe9e21619a7264dc25.tar.gz
gnu: perl: Fix cross-compilation.
* gnu/packages/perl.scm (perl)[arguments]: Use cross-libc instead of libc when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 79d8f3b684..03bd710aa9 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,7 +82,7 @@
"perl-reproducible-build-date.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:configure-flags
(let ((out (assoc-ref %outputs "out"))
(libc (assoc-ref %build-inputs "libc")))
@@ -130,7 +131,9 @@
(add-after 'install 'remove-extra-references
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (libc (assoc-ref inputs "libc"))
+ (libc (assoc-ref inputs
+ ,(if (%current-target-system)
+ "cross-libc" "libc")))
(config1 (car (find-files (string-append out "/lib/perl5")
"^Config_heavy\\.pl$")))
(config2 (find-files (string-append out "/lib/perl5")