summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-18 20:51:00 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-19 06:28:30 +0000
commit174c29a8e09456618eacabe15c8d4a1b0e5a6b10 (patch)
treea2ddf8292f2c3478d50c7140f5743d28b87ab389 /gnu
parent0ceb01a1ed86df0b7f5e57d90efba1949f73e480 (diff)
downloadguix-patches-174c29a8e09456618eacabe15c8d4a1b0e5a6b10.tar
guix-patches-174c29a8e09456618eacabe15c8d4a1b0e5a6b10.tar.gz
gnu: salmon: Use older version of TBB.
* gnu/packages/bioinformatics.scm (salmon)[arguments]: Define HAVE_NUMERIC_LIMITS128; compute TBB_VERSION. [inputs]: Replace tbb with tbb-for-salmon.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7b41c06bf6..816e64aedb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9726,9 +9726,10 @@ The following file formats are supported:
`(#:configure-flags
(list (string-append "-Dlibgff_DIR="
(assoc-ref %build-inputs "libgff") "/lib")
+ "-DCMAKE_CXX_FLAGS=\"-DHAVE_NUMERIC_LIMITS128=1\""
"-Dlibgff_FOUND=TRUE"
"-DTBB_FOUND=TRUE"
- "-DTBB_VERSION=2020.3"
+ ,(string-append "-DTBB_VERSION=" (package-version tbb-for-salmon))
"-DTBB_LIBRARIES=tbb -ltbbmalloc"
"-DFETCHED_PUFFERFISH=TRUE"
"-DUSE_SHARED_LIBS=TRUE")
@@ -9822,7 +9823,7 @@ The following file formats are supported:
(sha256
(base32
"0qb4a2nl1d59qasr17sslgxnkjd5kbk5mns4cjshrmsvkrqp995n"))))
- ("tbb" ,tbb)
+ ("tbb" ,tbb-for-salmon)
("libstadenio-for-salmon" ,libstadenio-for-salmon)
("xz" ,xz)
("zlib" ,zlib)))