summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-02-21 13:34:38 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-02-21 13:38:46 +0100
commite9bed5e9e7e4f9e6d92794fd159164cc0936a911 (patch)
tree370bda3315714536ce5f2fc4e6099933127a5480 /gnu/tests
parent7eefff2054b94f8a7ad850ad8f36b8773bb39ce9 (diff)
downloadguix-patches-e9bed5e9e7e4f9e6d92794fd159164cc0936a911.tar
guix-patches-e9bed5e9e7e4f9e6d92794fd159164cc0936a911.tar.gz
tests: nix: Fix it.
The <nix/config.nix> support has been removed in Nix 2.4: https://github.com/NixOS/nix/pull/4025. Rely on the store ping command instead to check that we can communicate with the daemon. * gnu/tests/package-management.scm (run-nix-test): Use the store ping command instead of building a dummy derivation.
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/package-management.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/tests/package-management.scm b/gnu/tests/package-management.scm
index fe897944d0..57c20291b4 100644
--- a/gnu/tests/package-management.scm
+++ b/gnu/tests/package-management.scm
@@ -85,22 +85,9 @@
'(begin
;; Wait for nix-daemon to be up and running.
(start-service 'nix-daemon)
- (with-output-to-file "guix-test.nix"
- (lambda ()
- (display "\
-with import <nix/config.nix>;
-
-derivation {
- system = builtins.currentSystem;
- name = \"guix-test\";
- builder = shell;
- args = [\"-c\" \"mkdir $out\\necho FOO > $out/foo\"];
- PATH = coreutils;
-}
-")))
- (zero? (system* (string-append #$nix "/bin/nix-build")
- "--substituters" "" "--debug" "--no-out-link"
- "guix-test.nix")))
+ (zero? (system* (string-append #$nix "/bin/nix")
+ "--experimental-features" "nix-command"
+ "store" "ping" "--store" "daemon")))
marionette))
(test-end))))