summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-11-15 17:23:08 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-15 17:55:50 +0100
commit21332f3b8cb8f407a89cdfe7d0460a9947675872 (patch)
tree92614af234e86663e8b2fe76e534d37b05848635 /gnu/tests
parent782e9975dc11e614fe38f9899806b968f9cd7d70 (diff)
downloadguix-patches-21332f3b8cb8f407a89cdfe7d0460a9947675872.tar
guix-patches-21332f3b8cb8f407a89cdfe7d0460a9947675872.tar.gz
gnu: hpcguix-web: Update to 0.2.0.
* gnu/packages/web.scm (hpcguix-web): Update to 0.2.0. [arguments]: In 'wrap-program' phase, add guile-zlib to DEPS. [native-inputs]: Add GUILE. [inputs]: Add GUILE-ZLIB, GUILE-COMMONMARK, and GUILE-JSON. [propagated-inputs]: Remove. These were pointless. * gnu/services/web.scm (<hpcguix-web-configuration>)[address, port]: New fields. * doc/guix.texi (Web Services): Document them. * gnu/tests/web.scm (%hpcguix-web-os): Add 'address'.
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/tests/web.scm b/gnu/tests/web.scm
index 518c9c1ff3..ccb2f53137 100644
--- a/gnu/tests/web.scm
+++ b/gnu/tests/web.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2020-2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
@@ -438,7 +438,8 @@ HTTP-PORT, along with php-fpm."
(service dhcp-client-service-type)
(service hpcguix-web-service-type
(hpcguix-web-configuration
- (specs %hpcguix-web-specs)))))
+ (specs %hpcguix-web-specs)
+ (address "0.0.0.0")))))
(define %test-hpcguix-web
(system-test