summaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-21 00:34:32 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-21 00:36:23 +0100
commit06da1a6b4fa919a64020ebf1a001b7e66134bd97 (patch)
treed4ecec28ab52712b5a1753732180350a4d70b282 /gnu/system
parentbb38ece4585679c27ecc1f5a063f75dfbf864a45 (diff)
downloadguix-patches-06da1a6b4fa919a64020ebf1a001b7e66134bd97.tar
guix-patches-06da1a6b4fa919a64020ebf1a001b7e66134bd97.tar.gz
gnu: Add qemu-minimal.
* gnu/packages/qemu.scm (qemu): Exchange with former QEMU-HEADLESS. (qemu-headless): Rename to... (qemu-minimal): ... this. New variable. Pass --target-list. * gnu/packages/debug.scm (qemu-2.3.0): Inherit from QEMU-MINIMAL. * gnu/packages/grub.scm (qemu-for-tests): Likewise. * gnu/system/vm.scm (expression->derivation-in-linux-vm, qemu-image): Update to name change.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/vm.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 96ff27f90b..1492a0bb1c 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -92,7 +92,7 @@
(system (%current-system))
(linux linux-libre)
initrd
- (qemu qemu-headless)
+ (qemu qemu-minimal)
(env-vars '())
(modules
'((gnu build vm)
@@ -185,7 +185,7 @@ made available under the /xchg CIFS share."
(define* (qemu-image #:key
(name "qemu-image")
(system (%current-system))
- (qemu qemu-headless)
+ (qemu qemu-minimal)
(disk-image-size (* 100 (expt 2 20)))
(disk-image-format "qcow2")
(file-system-type "ext4")