summaryrefslogtreecommitdiff
path: root/gnu/system/examples/bare-bones.tmpl
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 16:41:38 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit54d6223d2c240c0214c123e0b0aa977a01a3c209 (patch)
tree08abfe07481371e18ff13c76508b98a0c70efe70 /gnu/system/examples/bare-bones.tmpl
parent6f05630ba6848fa666f4ea57aab7f7ffbc15fc72 (diff)
downloadguix-patches-54d6223d2c240c0214c123e0b0aa977a01a3c209.tar
guix-patches-54d6223d2c240c0214c123e0b0aa977a01a3c209.tar.gz
doc: Rename OS config example.
* gnu/system/os-config.tmpl: Rename to... * gnu/system/examples/bare-bones.tmpl: ... this. * Makefile.am (EXAMPLES): Adjust accordingly. * doc.am (doc/os-config.texi): Likewise. * gnu/system/install.scm (configuration-template-service)[template]: Likewise.
Diffstat (limited to 'gnu/system/examples/bare-bones.tmpl')
-rw-r--r--gnu/system/examples/bare-bones.tmpl47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/system/examples/bare-bones.tmpl b/gnu/system/examples/bare-bones.tmpl
new file mode 100644
index 0000000000..e14c95733a
--- /dev/null
+++ b/gnu/system/examples/bare-bones.tmpl
@@ -0,0 +1,47 @@
+;; This is an operating system configuration template.
+
+(use-modules (gnu))
+(use-service-modules xorg networking dbus avahi)
+(use-package-modules xorg avahi)
+
+(operating-system
+ (host-name "antelope")
+ (timezone "Europe/Paris")
+ (locale "en_US.UTF-8")
+
+ ;; Assuming /dev/sdX is the target hard disk, and "root" is
+ ;; the label of the target root file system.
+ (bootloader (grub-configuration (device "/dev/sdX")))
+ (file-systems (cons (file-system
+ (device "root")
+ (title 'label)
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+
+ ;; This is where user accounts are specified. The "root"
+ ;; account is implicit, and is initially created with the
+ ;; empty password.
+ (users (list (user-account
+ (name "alice")
+ (comment "Bob's sister")
+ (group "users")
+
+ ;; Adding the account to the "wheel" group
+ ;; makes it a sudoer. Adding it to "audio"
+ ;; and "video" allows the user to play sound
+ ;; and access the webcam.
+ (supplementary-groups '("wheel"
+ "audio" "video"))
+ (home-directory "/home/alice"))))
+
+ ;; Globally-installed packages.
+ (packages (cons xterm %base-packages))
+
+ ;; Add services to the baseline: the SLiM log-in manager
+ ;; for Xorg sessions, a DHCP client, Avahi, and D-Bus.
+ (services (cons* (slim-service)
+ (dhcp-client-service)
+ (avahi-service)
+ (dbus-service (list avahi))
+ %base-services)))