summaryrefslogtreecommitdiff
path: root/gnu/system.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-10-08 17:21:09 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-10-10 10:22:08 +0200
commitce3801506652dcfeec983a66c4cba88c270891e8 (patch)
tree003b93da1d2b9e8fa9dac3e41c1bb09ec14beae9 /gnu/system.scm
parent4792a0321a5163ed043d404925c8ab03efae1223 (diff)
downloadguix-patches-ce3801506652dcfeec983a66c4cba88c270891e8.tar
guix-patches-ce3801506652dcfeec983a66c4cba88c270891e8.tar.gz
system: operating-system-etc-service: Set XCURSOR_PATH.
* gnu/system.scm (operating-system-etc-service): Set XCURSOR_PATH environment variable so that libxcursor finds cursors in user and system profiles. * gnu/packages/xorg.scm (libxcursor): Add a TODO for better handling of XCURSOR_PATH in other profiles.
Diffstat (limited to 'gnu/system.scm')
-rw-r--r--gnu/system.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/system.scm b/gnu/system.scm
index 0e834ba5ed..5f562b48bb 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -583,6 +583,9 @@ export INFOPATH=$HOME/.guix-profile/share/info:/run/current-system/profile/share
export XDG_DATA_DIRS=$HOME/.guix-profile/share:/run/current-system/profile/share
export XDG_CONFIG_DIRS=$HOME/.guix-profile/etc/xdg:/run/current-system/profile/etc/xdg
+# Make sure libXcursor finds cursors installed into user or system profiles. See <http://bugs.gnu.org/24445>
+export XCURSOR_PATH=$HOME/.icons:$HOME/.guix-profile/share/icons:/run/current-system/profile/share/icons
+
# Ignore the default value of 'PATH'.
unset PATH