summaryrefslogtreecommitdiff
path: root/gnu/system.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-30 15:40:07 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-08 14:26:14 +0200
commit68d8c094659565fe19abc1c433a17337ce5cacb7 (patch)
tree4f97b2413193eab93839f647a5cdcca9575dab7b /gnu/system.scm
parentb37c544196898cc3dfa3da07ed344fbe11abc120 (diff)
downloadguix-patches-68d8c094659565fe19abc1c433a17337ce5cacb7.tar
guix-patches-68d8c094659565fe19abc1c433a17337ce5cacb7.tar.gz
gnu: services: Add %hurd-startup-service.
This decouples startup of the Hurd from the "hurd" package, moving the RC script into SYSTEM. * gnu/packages/hurd.scm (hurd)[inputs]: Remove hurd-rc-script. [arguments]: Do not substitute it. Update "runsystem.sh" to parse kernel arguments and exec into --system=SYSTEM/rc. (hurd-rc-script): Move to... * gnu/services.scm (%hurd-rc-file): ...this new variable. (hurd-rc-entry): New procedure. (%hurd-startup-service): Use it in new variable. * gnu/system.scm (hurd-default-essential-services): Use it.
Diffstat (limited to 'gnu/system.scm')
-rw-r--r--gnu/system.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/system.scm b/gnu/system.scm
index 88b208277e..21d0fbd190 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -602,6 +602,7 @@ bookkeeping."
(define (hurd-default-essential-services os)
(list (service system-service-type '())
%boot-service
+ %hurd-startup-service
%activation-service
%shepherd-root-service
(service user-processes-service-type)