summaryrefslogtreecommitdiff
path: root/gnu/system.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
commit5bace4c8ad981b66b5c0769b885d0bb0db91a029 (patch)
tree0f2fb95c23d7990d26aeed71590bb94a3f2e17fe /gnu/system.scm
parent653569e878f39345b05110b998f10db3b520ccfe (diff)
parent20d87dfb453cf27f95c5ef3858e8d096278e1702 (diff)
downloadguix-patches-5bace4c8ad981b66b5c0769b885d0bb0db91a029.tar
guix-patches-5bace4c8ad981b66b5c0769b885d0bb0db91a029.tar.gz
Merge branch 'master' into core-updates
Conflicts: * gnu/packages/tls.scm (gnutls): Incorporated 3.5.13 graft (88e2511e217f2).
Diffstat (limited to 'gnu/system.scm')
-rw-r--r--gnu/system.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/system.scm b/gnu/system.scm
index b197abcdcc..580159a946 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -104,7 +104,7 @@
boot-parameters?
boot-parameters-label
boot-parameters-root-device
- boot-parameters-boot-name
+ boot-parameters-bootloader-name
boot-parameters-store-device
boot-parameters-store-mount-point
boot-parameters-kernel
@@ -216,7 +216,7 @@ directly by the user."
;; exactly to the device field of the <file-system> object representing the
;; OS's root file system, so it might be a device path like "/dev/sda3".
(root-device boot-parameters-root-device)
- (boot-name boot-parameters-boot-name)
+ (bootloader-name boot-parameters-bootloader-name)
(store-device boot-parameters-store-device)
(store-mount-point boot-parameters-store-mount-point)
(kernel boot-parameters-kernel)
@@ -235,8 +235,8 @@ directly by the user."
(label label)
(root-device root)
- (boot-name
- (match (assq 'boot-name rest)
+ (bootloader-name
+ (match (assq 'bootloader-name rest)
((_ args) args)
(#f 'grub))) ; for compatibility reasons.
@@ -306,7 +306,7 @@ The object has its kernel-arguments extended in order to make it bootable."
(boot-parameters
(label (menu-entry-label menu-entry))
(root-device #f)
- (boot-name 'custom)
+ (bootloader-name 'custom)
(store-device #f)
(store-mount-point #f)
(kernel (menu-entry-linux menu-entry))
@@ -892,7 +892,7 @@ kernel arguments for that derivation to <boot-parameters>."
(store -> (operating-system-store-file-system os))
(bootloader -> (bootloader-configuration-bootloader
(operating-system-bootloader os)))
- (boot-name -> (bootloader-name bootloader))
+ (bootloader-name -> (bootloader-name bootloader))
(label -> (kernel->boot-label (operating-system-kernel os))))
(return (boot-parameters
(label label)
@@ -903,7 +903,7 @@ kernel arguments for that derivation to <boot-parameters>."
(operating-system-kernel-arguments os system.drv root-device)
(operating-system-user-kernel-arguments os)))
(initrd initrd)
- (boot-name boot-name)
+ (bootloader-name bootloader-name)
(store-device (fs->boot-device store))
(store-mount-point (file-system-mount-point store))))))
@@ -929,7 +929,7 @@ being stored into the \"parameters\" file)."
(kernel-arguments
#$(boot-parameters-kernel-arguments params))
(initrd #$(boot-parameters-initrd params))
- (boot-name #$(boot-parameters-boot-name params))
+ (bootloader-name #$(boot-parameters-bootloader-name params))
(store
(device #$(boot-parameters-store-device params))
(mount-point #$(boot-parameters-store-mount-point params))))