summaryrefslogtreecommitdiff
path: root/gnu/services/avahi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-09 15:16:09 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-09 15:17:41 +0100
commita68fdfea96370c8a4b95af1fcd6e2fd7eb72da29 (patch)
tree681d676b54df9273b5216602ca01974994589515 /gnu/services/avahi.scm
parent8f8842cc7be41cdf55c240352f03db5f55d7881f (diff)
downloadguix-patches-a68fdfea96370c8a4b95af1fcd6e2fd7eb72da29.tar
guix-patches-a68fdfea96370c8a4b95af1fcd6e2fd7eb72da29.tar.gz
services: avahi: Default to nss-mdns 0.10.
This works around <https://bugs.gnu.org/30396>. Reported by George myglc2 Clemmer <myglc2@gmail.com>. * gnu/packages/avahi.scm (nss-mdns-0.10): New variable. * gnu/services/avahi.scm (avahi-service-type): Use it.
Diffstat (limited to 'gnu/services/avahi.scm')
-rw-r--r--gnu/services/avahi.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/services/avahi.scm b/gnu/services/avahi.scm
index d69c89f751..b4f89c4abf 100644
--- a/gnu/services/avahi.scm
+++ b/gnu/services/avahi.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,8 +131,10 @@ service switch (NSS) with support for @code{.local} host name resolution.")
(const %avahi-accounts))
(service-extension activation-service-type
(const %avahi-activation))
+
+ ;; Use 0.10 due to <https://bugs.gnu.org/30396>.
(service-extension nscd-service-type
- (const (list nss-mdns)))
+ (const (list nss-mdns-0.10)))
;; Provide 'avahi-browse', 'avahi-resolve', etc. in
;; the system profile.