summaryrefslogtreecommitdiff
path: root/gnu/platforms/s390.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-05-02 12:54:44 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-22 15:15:32 +0200
commit31f7696be4a2b2f9e54639a549f7ded32e68260b (patch)
tree493688e8fd21ab791f202cee15b4b6f65081afcd /gnu/platforms/s390.scm
parent6e0b2adf5f80d42f3a0e09e7de2bcfe188678997 (diff)
downloadguix-patches-31f7696be4a2b2f9e54639a549f7ded32e68260b.tar
guix-patches-31f7696be4a2b2f9e54639a549f7ded32e68260b.tar.gz
platform: Introduce new platforms.
* gnu/platforms/intel.scm: New file. * gnu/platforms/mips.scm: Ditto. * gnu/platforms/powerpc.scm: Ditto. * gnu/platforms/riscv.scm: Ditto. * gnu/platforms/s390.scm: Ditto. * gnu/local.mk (GNU_SYSTEM_MODULES): Add them. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/platforms/s390.scm')
-rw-r--r--gnu/platforms/s390.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/platforms/s390.scm b/gnu/platforms/s390.scm
new file mode 100644
index 0000000000..c8caafbe45
--- /dev/null
+++ b/gnu/platforms/s390.scm
@@ -0,0 +1,29 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu platforms s390)
+ #:use-module (gnu platform)
+ #:use-module (gnu packages linux)
+ #:use-module (guix records)
+ #:export (s390x-linux))
+
+(define s390x-linux
+ (platform
+ (target "s390x-linux-gnu")
+ (system "s390x-linux")
+ (linux-architecture "s390")))