summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-07 17:41:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-07 17:41:51 +0100
commitff9edc2c82bedc593858f10649c2649f98329818 (patch)
tree54ca0cfdf92435d2a345e0ec5e0915958b3cf253 /gnu/packages
parent1450bd3137eae78088a7ef94cbc5b4fe86e9ff14 (diff)
downloadguix-patches-ff9edc2c82bedc593858f10649c2649f98329818.tar
guix-patches-ff9edc2c82bedc593858f10649c2649f98329818.tar.gz
gnu: valgrind: Fix test failure with glibc 2.26.
* gnu/packages/patches/valgrind-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/valgrind.scm (valgrind)[source](patches): Use it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/valgrind-glibc-compat.patch18
-rw-r--r--gnu/packages/valgrind.scm3
2 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/patches/valgrind-glibc-compat.patch b/gnu/packages/patches/valgrind-glibc-compat.patch
new file mode 100644
index 0000000000..4f8effd207
--- /dev/null
+++ b/gnu/packages/patches/valgrind-glibc-compat.patch
@@ -0,0 +1,18 @@
+Fix build failure with glibc 2.26.
+
+Patch copied from upstream source repository:
+https://sourceware.org/git/?p=valgrind.git;a=commit;h=2b5eab6a8db1b0487a3ad7fc4e7eeda6d3513626
+
+diff --git a/memcheck/tests/linux/stack_changes.c b/memcheck/tests/linux/stack_changes.c
+index a978fc2..7f97b90 100644
+--- a/memcheck/tests/linux/stack_changes.c
++++ b/memcheck/tests/linux/stack_changes.c
+@@ -10,7 +10,7 @@
+ // This test is checking the libc context calls (setcontext, etc.) and
+ // checks that Valgrind notices their stack changes properly.
+
+-typedef struct ucontext mycontext;
++typedef ucontext_t mycontext;
+
+ mycontext ctx1, ctx2, oldc;
+ int count;
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 611a9a0558..d23cd7325b 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -39,7 +39,8 @@
(sha256
(base32
"18bnrw9b1d55wi1wnl68n25achsp9w48n51n1xw4fwjjnaal7jk7"))
- (patches (search-patches "valgrind-enable-arm.patch"))))
+ (patches (search-patches "valgrind-enable-arm.patch"
+ "valgrind-glibc-compat.patch"))))
(build-system gnu-build-system)
(outputs '("doc" ;16 MB
"out"))