summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-27 22:19:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 00:33:47 +0100
commitff3375251d6a316e3ee05589d70a8bb135ec47a6 (patch)
tree3bb25cc788c63f336687451a3337f681cc669bd3 /gnu/packages
parentdcc7fad0016d7ef062ccfe0b1deb3368251e8ff8 (diff)
downloadguix-patches-ff3375251d6a316e3ee05589d70a8bb135ec47a6.tar
guix-patches-ff3375251d6a316e3ee05589d70a8bb135ec47a6.tar.gz
gnu: Use the test-only Xorg variant for tests.
* gnu/packages/education.scm (gcompris-qt)[native-inputs]: Change XORG-SERVER to XORG-SERVER-FOR-TESTS. * gnu/packages/engineering.scm (pcb, qucs, openscad)[native-inputs]: Likewise. * gnu/packages/gnome.scm (libbonoboui, d-feet, gspell, libdazzle, libhandy)[native-inputs]: Likewise. * gnu/packages/gnupg.scm (parcimonie)[native-inputs]: Likewise. * gnu/packages/graphics.scm (opensubdiv, rapicorn)[native-inputs]: Likewise. * gnu/packages/gtk.scm (gtksourceview-2, gtksourceview)[native-inputs]: Likewise. * gnu/packages/image-processing.scm (opencv)[native-inputs]: Likewise. * gnu/packages/kde-frameworks.scm (kconfig, kcoreaddons, kwidgetsaddons, kwindowsystem, kdeclarative)[native-inputs]: Likewise. * gnu/packages/kde-plasma.scm (kscreenlocker)[native-inputs]: Likewise. * gnu/packages/messaging.scm (gajim)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-seaborn)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/education.scm2
-rw-r--r--gnu/packages/engineering.scm6
-rw-r--r--gnu/packages/gnome.scm10
-rw-r--r--gnu/packages/gnupg.scm2
-rw-r--r--gnu/packages/graphics.scm4
-rw-r--r--gnu/packages/gtk.scm4
-rw-r--r--gnu/packages/image-processing.scm2
-rw-r--r--gnu/packages/kde-frameworks.scm10
-rw-r--r--gnu/packages/kde-plasma.scm2
-rw-r--r--gnu/packages/messaging.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/vim.scm2
12 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index c84fa54223..46262fd14b 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -167,7 +167,7 @@ of categories with some of the activities available in that category.
("gettext" ,gettext-minimal)
("perl" ,perl)
("qttools" ,qttools)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("openssl" ,openssl)
("python-2" ,python-2)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 294105a757..c5e2f58aeb 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -373,7 +373,7 @@ features.")))
("imagemagick" ,imagemagick)
("gerbv" ,gerbv)
("ghostscript" ,ghostscript)
- ("xvfb" ,xorg-server)))
+ ("xvfb" ,xorg-server-for-tests)))
(home-page "http://pcb.geda-project.org/")
(synopsis "Design printed circuit board layouts")
(description
@@ -1771,7 +1771,7 @@ parallel computing platforms. It also supports serial execution.")
("python" ,python-2) ; for tests
("matplotlib" ,python2-matplotlib) ; for tests
("numpy" ,python2-numpy) ; for tests
- ("xorg-server" ,xorg-server))) ; for tests
+ ("xorg-server" ,xorg-server-for-tests))) ; for tests
(inputs
`(("adms" ,adms)
("asco" ,asco)
@@ -2174,7 +2174,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
("imagemagick" ,imagemagick)
("ps" ,procps)
("python" ,python)
- ("xvfb" ,xorg-server)))
+ ("xvfb" ,xorg-server-for-tests)))
(arguments
`(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index af2558d814..11ed035919 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2025,7 +2025,7 @@ since ca. 2006, when GTK+ itself incorporated printing support.")
(native-inputs
`(("glib" ,glib "bin") ; for glib-genmarshal, etc.
("intltool" ,intltool)
- ("xorg-server" ,xorg-server) ; For running the tests
+ ("xorg-server" ,xorg-server-for-tests) ; For running the tests
("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/libbonoboui/")
(synopsis "Some user interface controls using Bonobo")
@@ -4591,7 +4591,7 @@ principles are simplicity and standards compliance.")
("pkg-config" ,pkg-config)
("python-pep8" ,python-pep8)
("xmllint" ,libxml2)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("gobject-introspection" ,gobject-introspection)
("gtk+" ,gtk+)
@@ -7752,7 +7752,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
;; For tests.
("aspell-dict-en" ,aspell-dict-en)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(propagated-inputs
`(("enchant" ,enchant))) ;enchant.pc is required by gspell-1.pc
(home-page "https://wiki.gnome.org/Projects/gspell")
@@ -8167,7 +8167,7 @@ hexadecimal or ASCII. It is useful for editing binary files in general.")
`(("glib" ,glib "bin") ; glib-compile-resources
("pkg-config" ,pkg-config)
;; For tests.
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("glib" ,glib)
("gobject-introspection" ,gobject-introspection)
@@ -8389,9 +8389,9 @@ advanced image management tool")
("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
- ("xorg-server" ,xorg-server)
;; Test suite dependencies.
+ ("xorg-server" ,xorg-server-for-tests)
("hicolor-icon-theme" ,hicolor-icon-theme)))
(home-page "https://source.puri.sm/Librem5/libhandy")
(synopsis "Library full of GTK+ widgets for mobile phones")
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 6b6b8f616d..23d3aba90e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1045,7 +1045,7 @@ files, to verify signatures, and to manage the private and public keys.")
("perl-xml-twig" ,perl-xml-twig)
("torsocks" ,torsocks)))
(native-inputs
- `(("xorg-server" ,xorg-server)))
+ `(("xorg-server" ,xorg-server-for-tests)))
(arguments
`(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4f1c50b272..8795107dcb 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -758,7 +758,7 @@ realistic reflections, shading, perspective and other effects.")
("graphviz" ,graphviz)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
- ("xvfb" ,xorg-server)))
+ ("xvfb" ,xorg-server-for-tests)))
(home-page "https://rapicorn.testbit.org/")
(synopsis "Toolkit for rapid development of user interfaces")
(description
@@ -1055,7 +1055,7 @@ requirements.")
(setenv "DISPLAY" ":1")
#t)))))
(native-inputs
- `(("xorg-server" ,xorg-server)))
+ `(("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("glew" ,glew)
("libxrandr" ,libxrandr)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e6b9042c00..817c03c30e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -360,7 +360,7 @@ diagrams.")
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config)
;; For testing.
- ("xorg-server" ,xorg-server)
+ ("xorg-server" ,xorg-server-for-tests)
("shared-mime-info" ,shared-mime-info)))
(propagated-inputs
;; As per the pkg-config file.
@@ -431,7 +431,7 @@ printing and other features typical of a source code editor.")
("pkg-config" ,pkg-config)
("vala" ,vala)
;; For testing.
- ("xorg-server" ,xorg-server)
+ ("xorg-server" ,xorg-server-for-tests)
("shared-mime-info" ,shared-mime-info)))
(propagated-inputs
;; gtksourceview-3.0.pc refers to all these.
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 2579da3d6a..1961b47361 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -373,7 +373,7 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
(zero? (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp)))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server) ; For running the tests
+ ("xorg-server" ,xorg-server-for-tests) ; For running the tests
("opencv-extra"
,(origin
(method git-fetch)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ec735d8903..6f7c5df7b4 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -483,7 +483,7 @@ Internet).")
("extra-cmake-modules" ,extra-cmake-modules)
("inetutils" ,inetutils)
("qttools" ,qttools)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("qtbase" ,qtbase)))
(arguments
@@ -548,7 +548,7 @@ propagate their changes to their respective configuration files.")
("qttools" ,qttools)
("shared-mime-info" ,shared-mime-info)
;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
- ("xorg-server" ,xorg-server))) ; for the tests
+ ("xorg-server" ,xorg-server-for-tests))) ; for the tests
(inputs
`(("qtbase" ,qtbase)))
(arguments
@@ -1041,7 +1041,7 @@ represented by a QPoint or a QSize.")
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("qtbase" ,qtbase)))
(arguments
@@ -1091,7 +1091,7 @@ configuration pages, message boxes, and password requests.")
("dbus" ,dbus) ; for the tests
("openbox" ,openbox) ; for the tests
("qttools" ,qttools)
- ("xorg-server" ,xorg-server))) ; for the tests
+ ("xorg-server" ,xorg-server-for-tests))) ; for the tests
(inputs
`(("libxrender" ,libxrender)
("qtbase" ,qtbase)
@@ -2201,7 +2201,7 @@ their settings.")
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("kauth" ,kauth)
("kbookmarks" ,kbookmarks)
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index c1731d459a..d381ae9fb4 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -96,7 +96,7 @@ manager which re-parents a Client window to a window decoration frame.")
;; For tests.
("dbus" ,dbus)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("kcmutils" ,kcmutils)
("kcrash" ,kcrash)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 33e752c9a0..2429bad3e5 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -644,7 +644,7 @@ else [])"))
(native-inputs
`(("intltool" ,intltool)
("python-docutils" ,python-docutils)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("adwaita-icon-theme" ,adwaita-icon-theme)
("gnome-keyring" ,gnome-keyring)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9e726e8fc..7343366cd9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6310,7 +6310,7 @@ SVG, EPS, PNG and terminal output.")
("python-scipy" ,python-scipy)))
(native-inputs
`(("python-pytest" ,python-pytest)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-for-tests)))
(home-page "http://stanford.edu/~mwaskom/software/seaborn/")
(synopsis "Statistical data visualization")
(description
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ae07bcd9b6..b360d1fcbe 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -198,7 +198,7 @@ with the editor vim.")))
display " &")))))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server)
+ ("xorg-server" ,xorg-server-for-tests)
,@(package-native-inputs vim)))
(inputs
`(("acl" ,acl)