summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-17 20:32:18 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-18 09:22:08 +0200
commitff11a9f449e2f259faabebd075ce2ae1e13d27c2 (patch)
tree45a402b3f0d88af288241818d80aeb2f9938a226 /gnu/packages
parent0ac95b4490f2b661370b29980f6f01d28d03db6a (diff)
downloadguix-patches-ff11a9f449e2f259faabebd075ce2ae1e13d27c2.tar
guix-patches-ff11a9f449e2f259faabebd075ce2ae1e13d27c2.tar.gz
gnu: Add cl-shasht.
* gnu/packages/lisp-xyz.scm (sbcl-shasht, ecl-shasht, cl-shasht): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 64955a13f6..e61170e403 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16644,3 +16644,37 @@ all kind of typesetting applications.")
(define-public cl-typesetting
(sbcl-package->cl-source-package sbcl-cl-typesetting))
+
+(define-public sbcl-shasht
+ (let ((commit "4055327ef8e2aaa8627892ab256350ff3cb15e3c")
+ (revision "1"))
+ (package
+ (name "sbcl-shasht")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yitzchak/shasht")
+ (commit commit)))
+ (file-name (git-file-name "shasht" version))
+ (sha256
+ (base32 "01mh20s5gj0lajq45anxji77ykq1wcg72mn1y9a1k8i7q1ainjlr"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("parachute" ,sbcl-parachute)))
+ (inputs
+ `(("trivial-do" ,sbcl-trivial-do)))
+ (home-page "https://yitzchak.github.io/shasht/")
+ (synopsis "Common Lisp JSON reading and writing library")
+ (description
+ "This package provides a Common Lisp library to work with the JSON file
+format.")
+ (license license:expat))))
+
+(define-public ecl-shasht
+ (sbcl-package->ecl-package sbcl-shasht))
+
+(define-public cl-shasht
+ (sbcl-package->cl-source-package sbcl-shasht))