summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 21:49:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:43 +0100
commitfe94cf0cdd8f94599fa79f163257a1feea4946e8 (patch)
tree5d9214f3d373a6984f0d88a998cea0fbcd1fe51b /gnu/packages
parent213d1745c6adbfd274b1edc575529e026b0ab743 (diff)
downloadguix-patches-fe94cf0cdd8f94599fa79f163257a1feea4946e8.tar
guix-patches-fe94cf0cdd8f94599fa79f163257a1feea4946e8.tar.gz
gnu: Add python-rst.linker, python2-rst.linker.
* gnu/packages/python.scm (python-rst.linker, python2-rst.linker): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 36317cf1ec..a261400383 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2796,6 +2796,36 @@ sources.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+(define-public python-rst.linker
+ (package
+ (name "python-rst.linker")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rst.linker" version))
+ (sha256
+ (base32
+ "0bh4lnj2p1nh0wf5pgxgfbrp27xhb1rinahkb5j7s3qprq6qn0sr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil-2)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ ;; Test would require path.py, which would introduce a cyclic dependence.
+ (arguments `(#:tests? #f))
+ ;; Note: As of version 1.7 the documentation is not worth building.
+ (home-page "https://github.com/jaraco/rst.linker")
+ (synopsis "Sphinx plugin to add links and timestamps")
+ (description "rst.linker allows to automatically replace text by a
+reStructuredText external reference or timestamps. It's primary purpose is to
+augment the changelog, but it can be used for other documents, too.")
+ (license license:expat)))
+
+(define-public python2-rst.linker
+ (package-with-python2 python-rst.linker))
+
(define-public python-feedgenerator
(package
(name "python-feedgenerator")