summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-18 10:43:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-23 10:48:48 +0200
commitfe6e477dfbcf39d5a6a3a11bf0bf86651a60fa7c (patch)
treeb6f31bf7df583bfe133b18fcf6efb4aa65c1f645 /gnu/packages
parent19bd25172cc216a5fa179ff478f65dd85cc6cb11 (diff)
downloadguix-patches-fe6e477dfbcf39d5a6a3a11bf0bf86651a60fa7c.tar
guix-patches-fe6e477dfbcf39d5a6a3a11bf0bf86651a60fa7c.tar.gz
gnu: Add emacs-corfu.
* gnu/packages/emacs-xyz.scm (emacs-corfu): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ddbd92583a..5efa470470 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2511,6 +2511,28 @@ Its features are:
;; Software is dual-licensed.
(license (list license:unlicense license:wtfpl2))))
+(define-public emacs-corfu
+ (package
+ (name "emacs-corfu")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/corfu")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xb2si8il6j2mkkiac6pcx2yj83n82j4rsxxcn7gprpzzm1f9j61"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/corfu")
+ (synopsis "Completion overlay region function")
+ (description "Corfu enhances the default completion in region function
+with a completion overlay. The current candidates are shown in a popup
+overlay below or above the point. Corfu can be considered the minimalistic
+@code{completion-in-region} counterpart of the Vertico minibuffer UI.")
+ (license license:gpl3+)))
+
(define-public emacs-direnv
(package
(name "emacs-direnv")