summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-11-02 18:04:45 -0400
committerMark H Weaver <mhw@netris.org>2013-11-03 23:26:37 -0500
commitfdbd19ea6b784d164986856414a0fd6c25dab7b2 (patch)
treecd7bc8da3c15208d0fdcdc109a4d5784e810bb2f /gnu/packages
parentdd863f1f39858bf9d3f1a9de4b4eccc8d3f75d62 (diff)
downloadguix-patches-fdbd19ea6b784d164986856414a0fd6c25dab7b2.tar
guix-patches-fdbd19ea6b784d164986856414a0fd6c25dab7b2.tar.gz
gnu: gd: fix deplibs check method for mips64.
* gnu/packages/patches/gd-mips64-deplibs-fix.patch: New file. * gnu/packages/gd.scm (gd): Add patch. * gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gd.scm5
-rw-r--r--gnu/packages/patches/gd-mips64-deplibs-fix.patch17
2 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 13bcd45f77..ce3db6709c 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -20,6 +20,7 @@
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (gnu packages)
#:use-module (gnu packages libpng)
#:use-module (gnu packages libjpeg)
#:use-module (gnu packages fontutils)
@@ -40,7 +41,9 @@
(uri "https://bitbucket.org/libgd/gd-libgd/get/GD_2_0_33.tar.gz")
(sha256
(base32
- "0yrbx8mj9pykyzm0zl1q86xlkdvkajcsf5jmg688vhw9yc5wmbbw"))))
+ "0yrbx8mj9pykyzm0zl1q86xlkdvkajcsf5jmg688vhw9yc5wmbbw"))
+ (patches
+ (list (search-patch "gd-mips64-deplibs-fix.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after
diff --git a/gnu/packages/patches/gd-mips64-deplibs-fix.patch b/gnu/packages/patches/gd-mips64-deplibs-fix.patch
new file mode 100644
index 0000000000..6231310cdb
--- /dev/null
+++ b/gnu/packages/patches/gd-mips64-deplibs-fix.patch
@@ -0,0 +1,17 @@
+Patch configure script to choose pass_all deplibs check method for
+linux-gnu* systems on mips64. This is a temporary hack until libgd
+bootstraps their build system with a newer libtool.
+
+Patch by Mark H Weaver <mhw@netris.org>.
+
+--- libgd-gd/src/configure.orig 2006-04-05 11:56:57.000000000 -0400
++++ libgd-gd/src/configure 2013-11-02 17:56:19.123995838 -0400
+@@ -4457,7 +4457,7 @@
+ # This must be Linux ELF.
+ linux-gnu*)
+ case $host_cpu in
+- alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | x86_64*)
++ alpha* | hppa* | i*86 | mips | mipsel | mips64 | mips64el | powerpc* | sparc* | ia64* | s390* | x86_64*)
+ lt_cv_deplibs_check_method=pass_all ;;
+ *)
+ # glibc up to 2.1.1 does not perform some relocations on ARM