summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTrevor Hass <thass@okstate.edu>2020-07-24 18:22:56 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-25 15:13:39 +0300
commitfb38560c82a86f6340a608653efb0db4bcf47b98 (patch)
tree72f374b7f2203b19559cace54907a610ac90fa28 /gnu/packages
parent30d6eb85dac539e19994f4637dfc60ecf8826c0b (diff)
downloadguix-patches-fb38560c82a86f6340a608653efb0db4bcf47b98.tar
guix-patches-fb38560c82a86f6340a608653efb0db4bcf47b98.tar.gz
gnu: Add azimuth.
* gnu/packages/games.scm (azimuth): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1a6c569fa7..91e4861680 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11668,3 +11669,40 @@ game.") ;thanks to Debian for description
"With PokerTH you can play the Texas holdem poker game, either against
computer opponents or against real players online.")
(license license:agpl3+)))
+
+(define-public azimuth
+ (package
+ (name "azimuth")
+ ;; Not marked as latest release, but it fixes a compiling issue
+ ;; and adds the install target.
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mdsteele/azimuth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1znfvpmqiixd977jv748glk5zc4cmhw5813zp81waj07r9b0828r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ ;; Build release version instead of debug version.
+ (add-after 'unpack 'set-release
+ (lambda _
+ (setenv "BUILDTYPE" "release") #t))
+ (add-after 'unpack 'fix-install ; set install directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile" (("/usr") (assoc-ref outputs "out"))) #t)))))
+ (inputs `(("sdl" ,sdl)))
+ (home-page "https://mdsteele.games/azimuth/")
+ (synopsis "Metroidvania game with vector graphics")
+ (description
+ "Pilot your ship inside a planet to find and rescue the colonists trapped
+inside the Zenith Colony.")
+ (license license:gpl3+)))